[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lmi-commits] [lmi] master bfd60ed 03/13: Rename primary root finder

From: Greg Chicares
Subject: [lmi-commits] [lmi] master bfd60ed 03/13: Rename primary root finder
Date: Sun, 4 Jul 2021 19:04:43 -0400 (EDT)

branch: master
commit bfd60ede6ae870250ddfa2260f5545ca9b55a3e0
Author: Gregory W. Chicares <gchicares@sbcglobal.net>
Commit: Gregory W. Chicares <gchicares@sbcglobal.net>

    Rename primary root finder
    The old monolithic decimal_root() having been refactored into a general
    and a decimal part, replaced 'decimal_' in the general one's name.
    Chose 'lmi_root' as the new name. 'lmi_zero' was considered, but that
    would suggest s/decimal_root/decimal_zero/, which could too easily be
    taken as meaning "0.0" (decimal) as opposed to 0x0 (a binary zero).
    The source file retains its 'zero' name nevertheless as homage to RPB.
 zero.hpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/zero.hpp b/zero.hpp
index 8a4aceb..2872d52 100644
--- a/zero.hpp
+++ b/zero.hpp
@@ -235,7 +235,7 @@ using RoundT = std::function<double(double)>;
 /// superfluous reevaluation.
 template<typename FunctionalType>
-root_type decimal_root
+root_type lmi_root
     (double          bound0
     ,double          bound1
     ,double          tolerance
@@ -456,7 +456,7 @@ root_type decimal_root
     round_to<double> const round_dec {decimals, r_to_nearest};
-    return decimal_root
+    return lmi_root
         ,0.5 * std::pow(10.0, -decimals)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]