[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] Linphone on iOS does not ring anymore reliably - pu

From: German Cancio
Subject: Re: [Linphone-users] Linphone on iOS does not ring anymore reliably - push notification not working
Date: Sun, 19 Sep 2021 19:05:03 +0200


I’d suggest you enable debug logs on the app and then check the log file for entries such as the following:

2021-09-16 08:28:48:232 [Linphone/iOS] MESSAGE (honeAppDelegate.m:560 ) [PushKit] Notification [0x280734480] received with payload : {
    aps =     {
        "call-id" = "be5d70c3-396a-47cb-a10e-1aea69860afd";
       "loc-key" = "IC_MSG";
        uuid = "<urn:uuid: bbb157d2-f5c0-005b-8302-442a615003ed>";

And also

2021-09-16 08:28:48:633 [Linphone/belle-sip] MESSAGE channel [0x103e00000]: received [2253] new bytes from [TLS://]:
Call-ID: be5d70c3-396a-47cb-a10e-1aea69860afd

The first log entry gives you the timestamp of when the push notification was received, the second one the timestamp of the SIP INVITE for the same call-ID.

Do you have this problem when on multiple mobile and Wifi networks? On some Wifi networks, iOS devices may be put to sleep which can cause push notifications to arrive (too) late.

Cheers Germán

On 19 Sep 2021, at 14:16, Martin Glaser <> wrote:

since a couple of weeks the Linphone App installed on my iPhone does not ring anymore when I receive a call as soon as the App is in the background or the phone is in standby.

Push Notification is activated and I use Linphone's VoIP server.

I have Linphone in use since 2017 and it was all the time ringing very realiably.

Before the issue started, I updated Linphone from version 4.4.1 to version 4.5.0. The reason why I did this update was that I received before a call while the battery was low enough to make the iPhone switch off while the phone was ringing and after that all the configuration of Linphone was gone. So I thought when I need to redo now all the configuration, I do the update before.
In May I did the update to version 4.4.1 and in this time I had to delete the Linphone App and re-install it, because the new version just crashed after the normal update (probably because of an incompatible configuration setting or something). After the re-install and re-configuration it worked allright again. So I thought, maybe there will be again a configuration problem after the upgrade to 4.5.0 and I did the update right away as I had to redo the configuration anyhow.

Does 4.5.0 have a bug that prevents the reliable ringing? Are there known problems with Apple's Notification system?

When I updated to Linphone 4.5.0 I still had iOS 14.3 on my iPhone. I upgraded meanwhile to iOS 14.7.1 but that did not improve the situation.

I tried various settings for Notifications but nothing helped.

Linphone 4.5.0 behaves in so far different to older versions as I recognize that it seems to stop running quite soon after it was put in the background. I recognize this, because Linphone shows me now nearly always the start screen when I pull Linphone back in the foreground. Before using 4.5.0 it was normally so the just the last selected Linphone screen (usually the dialpad) was shown again and the registration was redone.

The other interesting thing I recognized is, that when I receive a call and Linphone is not ringing and I open Linphone later (maybe a few minutes or even a few hours - I can see how much later, because the call will be picked up by an answering machine and I see when people actually called), then Linphone suddenly signals a call and rings. It is as if the Notification is stuck somewhere and once when I open Linphone it is delivered. When I take the call, for sure nothing helpful happens. I usually just cancel the call. But even then Linphone seems to be a little disrupted and needs a force-restart. When there were multiple calls with Linphone not ringing and I open Linphone later, the Linphone signals multiple calls that I have to cancel individually.

I saw on github that other users have opened already issues for similar problems. It seems nothing is happening there?
I tried the workaround provided in but the change of the account password did not help in my case.

If I can provide any logs or information that helps to fix the problem, I will happily do, but please guide me in detail what you want me to do.

I will be very grateful for any help on this as I am considerably handicapped with the current situation that Linphone does practically never ring when I receive a call. Linphone on my iPhone is the only phone I have. I stopped years ago to have another fixed-line phone in parallel, because Linphone was so reliable.

Best Regards

Martin Glaser

Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]