[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Linphone on iOS does not ring anymore reliably - push n

From: Martin Glaser
Subject: [Linphone-users] Linphone on iOS does not ring anymore reliably - push notification not working
Date: Sun, 19 Sep 2021 14:16:50 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.14.0

since a couple of weeks the Linphone App installed on my iPhone does not ring 
anymore when I receive a call as soon as the App is in the background or the 
phone is in standby.

Push Notification is activated and I use Linphone's VoIP server.

I have Linphone in use since 2017 and it was all the time ringing very 

Before the issue started, I updated Linphone from version 4.4.1 to version 
4.5.0. The reason why I did this update was that I received before a call while 
the battery was low enough to make the iPhone switch off while the phone was 
ringing and after that all the configuration of Linphone was gone. So I thought 
when I need to redo now all the configuration, I do the update before.
In May I did the update to version 4.4.1 and in this time I had to delete the 
Linphone App and re-install it, because the new version just crashed after the 
normal update (probably because of an incompatible configuration setting or 
something). After the re-install and re-configuration it worked allright again. 
So I thought, maybe there will be again a configuration problem after the 
upgrade to 4.5.0 and I did the update right away as I had to redo the 
configuration anyhow.

Does 4.5.0 have a bug that prevents the reliable ringing? Are there known 
problems with Apple's Notification system?

When I updated to Linphone 4.5.0 I still had iOS 14.3 on my iPhone. I upgraded 
meanwhile to iOS 14.7.1 but that did not improve the situation.

I tried various settings for Notifications but nothing helped.

Linphone 4.5.0 behaves in so far different to older versions as I recognize 
that it seems to stop running quite soon after it was put in the background. I 
recognize this, because Linphone shows me now nearly always the start screen 
when I pull Linphone back in the foreground. Before using 4.5.0 it was normally 
so the just the last selected Linphone screen (usually the dialpad) was shown 
again and the registration was redone.

The other interesting thing I recognized is, that when I receive a call and 
Linphone is not ringing and I open Linphone later (maybe a few minutes or even 
a few hours - I can see how much later, because the call will be picked up by 
an answering machine and I see when people actually called), then Linphone 
suddenly signals a call and rings. It is as if the Notification is stuck 
somewhere and once when I open Linphone it is delivered. When I take the call, 
for sure nothing helpful happens. I usually just cancel the call. But even then 
Linphone seems to be a little disrupted and needs a force-restart. When there 
were multiple calls with Linphone not ringing and I open Linphone later, the 
Linphone signals multiple calls that I have to cancel individually.

I saw on github that other users have opened already issues for similar 
problems. It seems nothing is happening there?
I tried the workaround provided in but the 
change of the account password did not help in my case.

If I can provide any logs or information that helps to fix the problem, I will 
happily do, but please guide me in detail what you want me to do.

I will be very grateful for any help on this as I am considerably handicapped 
with the current situation that Linphone does practically never ring when I 
receive a call. Linphone on my iPhone is the only phone I have. I stopped years 
ago to have another fixed-line phone in parallel, because Linphone was so 

Best Regards

 Martin Glaser

reply via email to

[Prev in Thread] Current Thread [Next in Thread]