[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] can't configure msilbc 2.0.3

From: Oleg Miloshev
Subject: Re: [Linphone-users] can't configure msilbc 2.0.3
Date: Thu, 9 Jun 2011 13:10:01 +0300 (EEST)

 Thank you for the answer Gerhard,

As I have no experience with Vim , I tried "export commands" the way I know :

address@hidden:~/Desktop/msilbc-2.0.3> export ILBC_CFLAGS=-I%{_includedir}/ilbc
address@hidden:~/Desktop/msilbc-2.0.3> export ILBC_LIBS="-L%{_libdir} -lilbc"
address@hidden:~/Desktop/msilbc-2.0.3> ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... /usr/x86_64-suse-linux/bin/ld
checking if the linker (/usr/x86_64-suse-linux/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/x86_64-suse-linux/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/x86_64-suse-linux/bin/ld -m elf_x86_64) 
supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for ORTP... yes
checking for MEDIASTREAMER... yes
checking for ILBC... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating msilbc.iss
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing libtool-hacking commands
address@hidden:~/Desktop/msilbc-2.0.3> make
/bin/sh ./libtool  --tag=CC   --mode=compile gcc -DPACKAGE_NAME=\"msilbc\" 
-I/usr/local/include   -D_REENTRANT -DORTP_INET6 -I/usr/local/include   
-I%{_includedir}/ilbc  -g -O2 -MT libmsilbc_la-ilbc.lo -MD -MP -MF 
.deps/libmsilbc_la-ilbc.Tpo -c -o libmsilbc_la-ilbc.lo `test -f 'ilbc.c' || 
echo './'`ilbc.c
libtool: compile:  gcc -DPACKAGE_NAME=\"msilbc\" -DPACKAGE_TARNAME=\"msilbc\" 
-DPACKAGE_VERSION=\"2.0.3\" "-DPACKAGE_STRING=\"msilbc 2.0.3\"" 
-DLT_OBJDIR=\".libs/\" -I. -D_REENTRANT -DORTP_INET6 -I/usr/local/include 
-D_REENTRANT -DORTP_INET6 -I/usr/local/include "-I%{_includedir}/ilbc" -g -O2 
-MT libmsilbc_la-ilbc.lo -MD -MP -MF .deps/libmsilbc_la-ilbc.Tpo -c ilbc.c  
-fPIC -DPIC -o .libs/libmsilbc_la-ilbc.o
mv -f .deps/libmsilbc_la-ilbc.Tpo .deps/libmsilbc_la-ilbc.Plo
/bin/sh ./libtool --tag=CC   --mode=link gcc -D_REENTRANT -DORTP_INET6 
-I/usr/local/include   -D_REENTRANT -DORTP_INET6 -I/usr/local/include   
-I%{_includedir}/ilbc  -g -O2 -module  -no-undefined  -o -rpath 
/usr/local/lib/mediastreamer/plugins libmsilbc_la-ilbc.lo -L/usr/local/lib 
-lortp -lpthread -lssl -lcrypto   -L/usr/local/lib -lmediastreamer -lortp 
-lpthread -lssl -lcrypto   -L%{_libdir} -lilbc 
./libtool: line 4984: cd: %{_libdir}: No such file or directory
libtool: link: cannot determine absolute directory name of `%{_libdir}'
make: *** [] Error 1

This time I was successful with "configure" , but I get sticked with "make". I 
do not know what that (libtool: link: cannot determine absolute directory name 
of `%{_libdir}') tells me so if there is a way to fix that I will be very 


 >-------- Оригинално писмо --------
 >От:  Gerhard Stengel 
 >Относно: Re: [Linphone-users] can't configure msilbc 2.0.3
 >До: address@hidden
 >Изпратено на: Сряда, 2011, Юни 8 19:33:24 EEST

 >Am Mittwoch, 8. Juni 2011, 14:41:19 schrieb Oleg Miloshev:
 >>  Hi, 
 >> I have just downloaded and tried to configure msiblc-2.0.3 source on 
 >> OpenSuse 11.4 x64 , but received the 
 >following :
 >> "configure: error: Package requirements (ilbc >= 0.0.0) were not met:
 >> No package 'ilbc' found"
 >> I have the ilbc pack installed with headers in /usr/include/ilbc and 
 >> libraries in /usr/lib64. 
 >> Then I also tried configure --with-ilbc=/usr/include, but received 
 >> "configure: WARNING: unrecognized options: --with-ilbc"
 >> What should I do in order to configure msilbc successfully.
 >> Thanks in advance.
 >> Olegue
 >> -----------------------------------------------------------------
 >> Една чанта никога не е достатъчна! Влез в клуба!
 >> _______________________________________________
 >> Linphone-users mailing list
 >> address@hidden
 >Hello Olegue,
 >the ilbc 2.0.3 gave me a lot of headache, too (using OS 11.4 x86_64 as well.)
 >Below's my fixed spec file.
 >Note my quick and dirty fix in the %build section.
 >The open SUSE package lacks the pkgconfig file, that's why.
 >You may file a bug report at openSUSE, if you like, I forgot to do that.
 ># vim: set sw=4 ts=4 et nu:
 ># norootforbuild
 >Name:               linphone-msilbc
 >Version:            2.0.3
 >Release:            gs.1
 >Summary:            iLBC Codec Plugin for Linphone
 >Source:             msilbc-%{version}.tar.bz2
 >Patch0:             linphone-msilbc-avoid_version.patch
 >Source99:           %{name}-rpmlintrc
 >Group:              Productivity/Networking/Other
 >License:            GNU General Public License version 2 or later (GPL v2 or 
 >BuildRoot:          %{_tmppath}/build-%{name}-%{version}
 >BuildRequires:      linphone-devel
 >BuildRequires:      ilbc
 >BuildRequires:      gcc make glibc-devel pkgconfig
 >BuildRequires:      autoconf automake libtool
 >Provides:           msilbc = %{version}
 >iLBC codec plugin for linphone.
 >%setup -q -n "msilbc-%{version}"
 >#This is a quick and dirty fix for the missing pkgconfig file ilbc.pc in the 
 >openSUSE 11.4 ilbc package.
 >#We don't have to check again if the package is really installed because it's 
 >listed in BuildRequires.
 >export ILBC_CFLAGS=-I%{_includedir}/ilbc
 >export ILBC_LIBS="-L%{_libdir} -lilbc"
 >%__make %{?jobs:-j%{jobs}}
 >%__rm -f "%{buildroot}%{_libdir}/mediastreamer/plugins"/*.{la,a}
 >%{?buildroot:%__rm -rf "%{buildroot}"}
 >%dir %{_libdir}/mediastreamer
 >%dir %{_libdir}/mediastreamer/plugins
 >* Tue Apr 18 2011 address@hidden
 >- update to version 2.0.3
 >* Sun Nov  7 2010 address@hidden
 >- initial package (2.0.1)
 >Linphone-users mailing list

Една чанта никога не е достатъчна! Влез в клуба!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]