[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] can't configure msilbc 2.0.3

From: Gerhard Stengel
Subject: Re: [Linphone-users] can't configure msilbc 2.0.3
Date: Wed, 8 Jun 2011 18:33:24 +0200
User-agent: KMail/1.13.7 (Linux/; KDE/4.6.3; x86_64; ; )

Am Mittwoch, 8. Juni 2011, 14:41:19 schrieb Oleg Miloshev:
>  Hi, 
> I have just downloaded and tried to configure msiblc-2.0.3 source on OpenSuse 
> 11.4 x64 , but received the 
following :
> "configure: error: Package requirements (ilbc >= 0.0.0) were not met:
> No package 'ilbc' found"
> I have the ilbc pack installed with headers in /usr/include/ilbc and 
> libraries in /usr/lib64. 
> Then I also tried configure --with-ilbc=/usr/include, but received 
> "configure: WARNING: unrecognized options: --with-ilbc"
> What should I do in order to configure msilbc successfully.
> Thanks in advance.
> Olegue
> -----------------------------------------------------------------
> Една чанта никога не е достатъчна! Влез в клуба!
> _______________________________________________
> Linphone-users mailing list
> address@hidden
Hello Olegue,

the ilbc 2.0.3 gave me a lot of headache, too (using OS 11.4 x86_64 as well.)

Below's my fixed spec file.

Note my quick and dirty fix in the %build section.
The open SUSE package lacks the pkgconfig file, that's why.
You may file a bug report at openSUSE, if you like, I forgot to do that.



# vim: set sw=4 ts=4 et nu:
# norootforbuild

Name:               linphone-msilbc
Version:            2.0.3
Release:            gs.1
Summary:            iLBC Codec Plugin for Linphone
Source:             msilbc-%{version}.tar.bz2
Patch0:             linphone-msilbc-avoid_version.patch
Source99:           %{name}-rpmlintrc
Group:              Productivity/Networking/Other
License:            GNU General Public License version 2 or later (GPL v2 or 
BuildRoot:          %{_tmppath}/build-%{name}-%{version}
BuildRequires:      linphone-devel
BuildRequires:      ilbc
BuildRequires:      gcc make glibc-devel pkgconfig
BuildRequires:      autoconf automake libtool
Provides:           msilbc = %{version}

iLBC codec plugin for linphone.

%setup -q -n "msilbc-%{version}"

#This is a quick and dirty fix for the missing pkgconfig file ilbc.pc in the 
openSUSE 11.4 ilbc package.
#We don't have to check again if the package is really installed because it's 
listed in BuildRequires.
export ILBC_CFLAGS=-I%{_includedir}/ilbc
export ILBC_LIBS="-L%{_libdir} -lilbc"

%__make %{?jobs:-j%{jobs}}


%__rm -f "%{buildroot}%{_libdir}/mediastreamer/plugins"/*.{la,a}

%{?buildroot:%__rm -rf "%{buildroot}"}

%dir %{_libdir}/mediastreamer
%dir %{_libdir}/mediastreamer/plugins

* Tue Apr 18 2011 address@hidden
- update to version 2.0.3
* Sun Nov  7 2010 address@hidden
- initial package (2.0.1)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]