[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] [SOLVED] Linphonec echo cancellation on a BeagleBoa

From: Dragos D
Subject: Re: [Linphone-users] [SOLVED] Linphonec echo cancellation on a BeagleBoard - extremely high CPU use.
Date: Tue, 21 Dec 2010 09:28:57 -0500

So how much of the processor is used now?

On Dec 21, 2010 6:26 AM, "Federico Lorenzi" <address@hidden> wrote:
> Sorry for the noise - looks like I fixed my own problem here.
> Recompiling Speex with --disable-float-api and --enable-fixed-point
> seems to have gotten everything working at good speed. Seems like the
> Ubuntu ARM package isn't compiled specially.
> On Tue, Dec 21, 2010 at 11:09 AM, Federico Lorenzi <address@hidden> wrote:
>> Hi everyone,
>> I'm running Ubuntu 10.10 on a BeagleBoard with the Linphone package
>> installed (3.3.2).
>> Calls work without the echo canceller, but are obviously quite echo-y.
>> The system is set up as a speakerphone essentially, and if I
>> understand correctly, this is one of the exact situations an acoustic
>> echo canceller is designed to help with. (As opposed to far end echo,
>> etc.)
>> I've tried various different numbers for the "ec on" parameters, but
>> no matter what I try (including numbers found at
>> CPU usage goes extremely high, and the call becomes choppy. Linphonec
>> is shown using all of the CPU in top.
>> If it counts for anything I'm using Ulaw and it's registered to an Asterisk box.
>> Cheers,
>> Federico
> _______________________________________________
> Linphone-users mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]