[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] RTP Stream Bug via VPN

From: Peio Rigaux
Subject: Re: [Linphone-developers] RTP Stream Bug via VPN
Date: Wed, 8 Jul 2020 20:02:28 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.9.0


I think that after a re-reading I have an idea.

I may be wrong, not knowing anything yet about ICE, STUN or TURN, but I think that you can add the following :



Replace it with your proxy address and according transport value, it seems to enable outbound proxy, i.e. redirection of media towards the "gateway" (I took a look at the Android code).

Make also sure that the proxy number is matching the right account.

Please tell me if you managed to get it working on desktop.


Peio Rigaux
Junior Software Engineer
Belledonne Communications, the company behind Linphone

Le 26/03/2020 à 16:57, Benny Puder a écrit :
Dear developers,

I'm part of a small company and would like to use linphone from the home office via VPN. The SIP registration works well but when the call is established, I don't hear anything from the counterpart. There is also no indication on the little icons that speech is transmitted. So I started to do some investigations.

I'm currently working on Ubuntu 18.04 and installed Linphone 4.1.1 from the flatpak repository as you described on the internet site. The VPN tunnel works fine. My ip configuration can be viewed in the attached file linphone-ipa.log. My computer has the VPN IP address and the local address for the internet connection.

The SIP gateway ( is located in the company network. This route is working properly and my pc can ping other pcs in the company and vice versa. I'm registering with username "16". No password is required.

I also attached the linphone log and a wireshark capture of the tunnel. There you can see that the session was established and the counterpart is sending RTP packets to the port 26935. This should be the right port as you can see in the INVITE message.

I had a short look on the netstat command and saw that linphone didn't listen on this port. But shouldn't it? I also attached the output of the netstat command before the call and during the call.

I also used linphone from my companies computer (also Ubuntu 18.04) and it worked well. I would guess that there is something wrong in conjunction with the VPN network. Or do I need to apply a special configuration? STUN/TURN/ICE related settings are still off or empty.

I also tried to use my android phone with VPN and linphone and it worked nearly fine. It was really important to switch on that all calls were redirected to the gateway. There are sometimes lost connections but maybe they have other reasons which are not related to linphone. This occurs very rarely.

Here are my settings on the computer. I only added the SIP account. I didn't change other settings.

Thank you for your time.

Linphone-developers mailing list

Attachment: 0x99D28356FED78143.asc
Description: application/pgp-keys

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]