[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] running the tutorials

From: Simon MORLAT
Subject: Re: [Linphone-developers] running the tutorials
Date: Fri, 16 Feb 2018 09:17:49 +0100

Hi Cameron,

The errors at startup relate to the fact that:
- no camera could be detected
- no soundcard could be detected
- DSCP tagging of RTP packet doesn't work (maybe due to insufficient permissions ?) - anyway this is not required to operate
Maybe you are doing your test in a virtual machine without sound device or camera configured ?

Anyway these errors are unrelated to the failure of the call, which is probably because your server requires an authentication with password, but the tutorial doesn't allow this (it is a very simple example).
I suggest that you modifiy the tutorial source code by using linphone_core_create_auth_info() and linphone_core_add_auth_info() to setup a password from command line.

Finally, regarding compilation of the project on windows, the easiest way is to clone the linphone-desktop project, because it includes most dependencies as git submodules.

git clone git:// --recursive
git checkout 4.1.1
git submodule update --init --recursive

4.1.1 is the last stable tag, but HEAD of master branch works as well.

Then follow the instructions in the in order to proceed with the compilation.

Best regards,


2018-01-19 5:06 GMT+01:00 Miller, Cameron <address@hidden>:

Greetings linphone developers,


I’ve just started my voip sdk journey and I tried the liblinphone basic call tutorial, but things aren’t working as expected.


I’ve got FreeSWITCH running on a windows server at

I’ve got a x-lite softphone running on the same server registered with address 1000.


I’ve got the liblinphone tutorial running on a windows 10 virtual machine

I attempt to dial the x-lite client.

Here is the results:


C:\Users\RTIS\Downloads\liblinphone tutorial>"Liblinphone tutorial.exe" sip:address@hidden

WARNING: no real random source present!

2018-01-18 16:59:48:893 ortp-error-Fail to create class enumerator.

2018-01-18 16:59:48:959 ortp-error-Could not find a suitable soundcard !

2018-01-18 16:59:48:960 ortp-error-Could not find a suitable soundcard !

2018-01-18 16:59:48:961 ortp-error-Could not find a suitable soundcard !

2018-01-18 16:59:48:963 ortp-warning-belle_sip_socket_set_dscp(): not implemented.

2018-01-18 16:59:48:966 ortp-warning-belle_sip_socket_set_dscp(): not implemented.

2018-01-18 16:59:48:967 ortp-warning-belle_sip_socket_set_dscp(): not implemented.

2018-01-18 16:59:48:971 ortp-error-QOSAddSocketToFlow failed to add a flow with error 87

2018-01-18 16:59:48:973 ortp-error-QOSAddSocketToFlow failed to add a flow with error 87

Call to sip:address@hidden is in progress...Terminating the call...

Shutting down...




The freeSWITCH console output look like this:


address@hidden> 2018-01-19 11:09:01.691655 [NOTICE] switch_channel.c:1104 New Channel sofia/internal/address@hidden168.0.2 [70d0436d-2e5d-49a7-ae54-59299eefeb33]

2018-01-19 11:09:12.052606 [WARNING] switch_core_state_machine.c:687 70d0436d-2e5d-49a7-ae54-59299eefeb33 sofia/internal/address@hidden168.0.2 Abandoned

2018-01-19 11:09:12.052606 [NOTICE] switch_core_state_machine.c:690 Hangup sofia/internal/address@hidden168.0.2 [CS_NEW] [WRONG_CALL_STATE]

2018-01-19 11:09:12.052606 [NOTICE] switch_core_session.c:1682 Session 33 (sofia/internal/address@hidden168.0.2) Ended

2018-01-19 11:09:12.052606 [NOTICE] switch_core_session.c:1686 Close Channel sofia/internal/address@hidden168.0.2 [CS_DESTROY]


The freeSWITCH server has a password, but this tutorial doesn’t accept one (for registration)…


Could I get some help with the liblinphone errors, please?





ps. I went back to visual studio and found all the tutorials use deprecated methods. I swapped over to the new methods (e.g. using factory) and the same errors occur. Please consider updating your tutorials to use current methods.

pps. I tried getting ortp source from git to investigate further, but the instructions for win32 were wrong (the win32 build folder was absent). I tried downloading it anyway, but got stuck with trying to resolve cmake dependencies on bctoolkit and then polarssl (I have no cmake experience).


Queensland Rail’s number one priority is safety. Queensland Rail has a program of testing for alcohol and illicit substances. Please be aware any person who enters a Queensland Rail premises for business purposes may be randomly tested for alcohol (breath test) and illicit substances (oral fluids test). Please also ensure you are wearing the appropriate Personal Protective Equipment for the site you are visiting. Call your Queensland Rail contact person if you need more information. This email (which includes all attachments and linked documents) is intended for and is confidential to the addressee; it may also be subject to legal professional privilege or otherwise protected from disclosure. If the addressee is a government agency in receipt of a Right to Information Act (2009) application in relation to this email, contact must be made with Queensland Rail ABN 68 598 268 528 in accordance with the third party consultation process provided for in Part 3, Division 3, Section 37 of that legislation. If you are not the addressee, or if you have received this email in error, you must not use, rely upon, disclose or reproduce it (or any part of it) in any way. Please notify the sender of your receipt of it and delete it in its entirety. Neither Queensland Rail (or any of its related entities) accepts any liability for computer viruses, data corruption, delay, interference, interception, unauthorised access or amendment of this email. The views expressed in this email, unless clearly stated otherwise, are the views of the sender. They do not necessarily represent the view or policy of Queensland Rail or any of its related entities.

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]