[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] SIP registration fails on IOS9.2 for TCP tranp

From: Gautier Pelloux-Prayer
Subject: Re: [Linphone-developers] SIP registration fails on IOS9.2 for TCP tranport
Date: Fri, 18 Mar 2016 09:32:22 +0100


This is interesting...  some people reported connection issues on real device 
while simulator was working just fine, so I believe there is something going 

Can you send logs so that we can check what's going on? Ideally I'd like to 
reproduce this issue, but yet it's working as expected using 


Gautier Pelloux-Prayer
Software Engineer @ Belledonne Communications

> On 18 Mar 2016, at 07:20, Ad Langenkamp <address@hidden> wrote:
> Hello
> I am developing an IOS client SIP client based on linphone-iphone (Phone iOS 
> 3.12.1 and Core 3.9.1). Well.. developing is a big statement since I am just 
> customizing the linphone-iphone source a bit to meet my needs. Downloaded the 
> source files and compiled them for use on regular devices (../ && 
> make). The code compiles just fine and runs on an IPAD with IOS9.2. Outgoing 
> calls work fine and incoming calls as well when the app is in the foreground. 
> As I noted in the mailing list that receiving calls in the background only 
> works when TCP transport is used, I tried switching to TCP in the settings, 
> but after having done so, the app will not register anymore. it fails 
> registration with an "unkown error" dialog.
> At first I suspected my service provider, but they support TCP.  To verify 
> that this is indeed the case I ran linphone downloaded form the google play 
> store on an android device and this device registers just fine over TCP with 
> the same provider. even TLS registration worked.
> Then I checked if the problem might be related with the sources I downloaded 
> , so I installed the official app store version of linphone on the same IPAD 
> and tried registering on the IPAD (IOS 9.2) over TCP. The official version 
> has the same problem. It refuses to register over TCP (only UDP works) and 
> the same "unknown error" feedback appears.
> Strangely the problem can not be reproduced when I run the code from either 
> the i386 nor the x86_64 simulators in Xcode; they all register just fine 
> using TCP.
> Has anyone experienced a similar issue on IOS 9.2? Is the problem particular 
> to IPAD or does it also occur on iPhone physical devices? Can you please 
> suggest a solution or a workaround in the code? 
> Thank you so much
> Ad Langenkamp 
> _______________________________________________
> Linphone-developers mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]