[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Followup response to yesterday's #3 & $4: Newb

From: Gautier Pelloux-Prayer
Subject: Re: [Linphone-developers] Followup response to yesterday's #3 & $4: Newbee problem building linphone-android
Date: Fri, 12 Jun 2015 10:16:46 +0200

What is the file system of /usr/local/linphone-android partition? In any case 
your installation seems very odd, before doing anything else, you should manage 
to execute script:

1) cd /usr/local/linphone-android/
2) sh ./ 

If not working, try in order:

3) bash ./
4) ls -l && file (copy output here)

By the way, please answer the current thread instead of creating a new email 
for each response so that one can follow the discussion easily.


Gautier Pelloux-Prayer
Software Engineer @ Belledonne Communications

> On 12 Jun 2015, at 02:43, William Hutchison <address@hidden> wrote:
> Thanks so much for the quick response!
> My OS is ubuntu-15.04-desktop-amd64 The uname -a gives me:
> [my computer name] 3.19.0-18-generic #18-Ubuntu SMP x86_64 GNU/Linux
> echo $SHELL gives:
> shell interpreter: /bin/bash
> When I modify head of from "#!/bin/sh" to "#!/bin/sh -x" and 
> execute verbosely using make V=1, it gives me:
> /bin/sh: 0: Illegal option -
> Makefile:80: No such file or directory
> Picked up JAVA_TOOLS_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar
> make: *** No rule to make target ''. Stop.
> So it doesn't like the -x. I also tried –x, and also previously had tried 
> chmod +x before doing the make, and also tried running it as 
> su, with no results. When I take out the -x again, and run in verbose mode, 
> the first line says the same as in my original posting, followed by the 3 
> lines above:
> make: ./ Command not found
> Makefile:80: No such file or directory
> Picked up JAVA_TOOLS_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar
> make: *** No rule to make target ''. Stop.
> As instructed, I'm in the console in the /usr/local/linphone-android/ 
> directory with all the git files, and have the tools, platform-tools, and 
> android-ndk-r10e directories in the same /usr/local directory with their 
> paths added to the .bashrc file, as follows:
> export PATH=${PATH}:/usr/local/tools
> export PATH=${PATH}:/usr/local/platform-tools
> export PATH=${PATH}:/usr/local/android-ndk-r10e
> I hope this is a little helpful diagnosing the problem.
> _______________________________________________
> Linphone-developers mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]