[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] Running master branch amd64 on xcode 6

From: Jason Sia
Subject: [Linphone-developers] Running master branch amd64 on xcode 6
Date: Tue, 16 Dec 2014 00:13:36 +0800


I've downloaded the master branch of linphone with 64 bit support I successfully compiled the submodules however when I try to link it to xcode and try to run it in iphone 5s simulator i get this error

warning: ignoring file <directory>/linphone-iphone/liblinphone-sdk/aarch64-apple-darwin/lib/libantlr3c.a, file was built for archive which is not the architecture being linked (x86_64): <directory>/linphone-iphone/liblinphone-sdk/aarch64-apple-darwin/lib/libantlr3c.a

and also all the other files produces the same error

Undefined symbols for architecture x86_64:

  "_OBJC_CLASS_$_TUNinePatch", referenced from:

      objc-class-ref in UILinphoneTextField.o

      objc-class-ref in UILinphoneButton.o

Does anyone tried compiling this in xcode?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]