[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Error compiling linphone web on Mac - fatal er

From: Saumil Gandhi
Subject: Re: [Linphone-developers] Error compiling linphone web on Mac - fatal error: 'linphone/linphonecore.h' file not found
Date: Wed, 2 Apr 2014 15:21:05 +0530

Hi Ghislain,

I got the latest source ( like you mentioned, it does not have the submodules directory that the old source did), added it to my firebreath/projects folder (after removing the previous plugin files completely), and tried to build it, but am getting the same error. 

I checked the build/Stage/include/linphone directory and the file is not present here. 


On Wed, Apr 2, 2014 at 1:20 PM, Ghislain MARY <address@hidden> wrote:

Are you sure your sources are up-to-date? We no longer use the git submodules to build the plugin. The linphonecore.h will be fetched automatically at compile time and will be located in the build/Stage/include/linphone directory.


On 31/03/2014 21:10, Saumil Gandhi wrote:

I'm trying to compile on a Mac, and am seeing errors on compilation of authinfoapi.cpp, addressapi.cpp, callapi.cpp, and calllogapi.cpp. For all,  the error is "fatal error: 'linphone/linphonecore.h' file not found".

Copying a sample error output:


In file included from /Users/Saumil/Documents/Dreamscape/connectgrams/firebreath/firebreath/projects/linphone-web-plugin/Src/calllogapi.cpp:25:
/Users/Saumil/Documents/Dreamscape/connectgrams/firebreath/firebreath/projects/linphone-web-plugin/Src/calllogapi.h:28:10: fatal error: 'linphone/linphonecore.h' file not found
#include <linphone/linphonecore.h>
1 error generated.


I checked and the linphonecore.h file is in my submodules/linphone/coreapi folder. What could be causing this? I'm on OSX 10.7.5, and trying to build with xcodebuild -arch i386


Linphone-developers mailing list

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]