[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] Android NDK Cygwin compilation bug

From: nicolas.canceill
Subject: [Linphone-developers] Android NDK Cygwin compilation bug
Date: Fri, 1 Apr 2011 17:49:33 +0200 (CEST)

Hello everyone,

I might have found a bug in the native compilation process for Android while using Cygwin on Windows XP.

After having compiled libiLBC, I launched ndk-build from the root directory of the project. It compiled linphone-core, but then it tried to compile mediastreamer and I got an error:

Compile arm    : mediastreamer2 <= mscommon.c
cc1.exe: error: /cygdrive/d/linphone-android/jni/..//submodules/linphone/mediastreamer2/build/android/../../src/../build/android/libmediastreamer2_AndroidConfig.h: No such file or directory

I thought the problem was the double slash in "/jni/..//submodules", so I edited in linphone-android/jni as follows:

The first line was:
APP_PROJECT_PATH := $(call my-dir)/../
I made it:
APP_PROJECT_PATH := $(call my-dir)/..

Then I launched ndk-build again, and I got the same error, except there was no double slash anymore:
cc1.exe: error: /cygdrive/d/linphone-android/jni/../submodules/linphone/mediastreamer2/build/android/../../src/../build/android/libmediastreamer2_AndroidConfig.h: No such file or directory

Of course, I checked: the file does indeed exist.

Can you confirm that the double slash induced by is a bug?

Do you have any idea about the main problem? (even with the right path, the compiler does not find libmediastreamer2_AndroidConfig.h).

I have the latest Cygwin.

Thanks and regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]