[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] port linphone-3.2.1 to arm board, no sound &

From: alex z
Subject: Re: [Linphone-developers] port linphone-3.2.1 to arm board, no sound & strange issue
Date: Tue, 22 Jun 2010 19:18:01 +0800


Any tips to debug alsa driver in linphone? Thanks!

2010/6/22 Harishkumar V <address@hidden>
oh, k

it might be alsa driver issue for your hardware.
which hardware ar u using.

On Tue, Jun 22, 2010 at 3:14 PM, alex z <address@hidden> wrote:
I think it's a buggy alsa driver issue. Because I use command to record a wav file:
arecord -D plughw:0,0 -f S16_LE -r 8000 /data/record.wav
and then in linphone, "play /data/record.wav", sound is ok.
Any tips?

2010/6/22 alex z <address@hidden>
Try this command and still keep silent.
 mediastream --local 8000 --remote --payload 0
See my last email for attached log.

2010/6/22 alex z <address@hidden>

I tried it, and attached is the log. And then?
Maybe I need a synchronizing timestamp implement?

2010/6/22 Harishkumar V <address@hidden>


try this to check whether local audio capture and playback is working,

mediastream --local 8000 --remote --payload 0

On Tue, Jun 22, 2010 at 8:22 AM, alex z <address@hidden> wrote:
some logs: 

  Audio session's RTP statistics :
ortp-message- number of rtp packet sent=28441
ortp-message- number of rtp bytes sent=4891852 bytes
ortp-message- number of rtp packet received=28302
ortp-message- number of rtp bytes received=4867944 bytes
ortp-message- number of incoming rtp bytes successfully delivered to the application=4825632
ortp-message- number of times the application queried a packet that didn't exist=56643
ortp-message- number of rtp packet lost=0
ortp-message- number of rtp packets received too late=243
ortp-message- number of bad formatted rtp packets=0
ortp-message- number of packet discarded because of queue overflow=0
ortp-message-ms_filter_unlink: MSAlsaRead:0x40bc8,0-->MSVolume:0x45048,0
ortp-message-ms_filter_unlink: MSVolume:0x45048,0-->MSAlawEnc:0x44f48,0
ortp-message-ms_filter_unlink: MSAlawEnc:0x44f48,0-->MSRtpSend:0x44180,0
ortp-message-ms_filter_unlink: MSRtpRecv:0x40ae8,0-->MSAlawDec:0x44fe8,0
ortp-message-ms_filter_unlink: MSAlawDec:0x44fe8,0-->MSDtmfGen:0x40b48,0
ortp-message-ms_filter_unlink: MSDtmfGen:0x40b48,0-->MSEqualizer:0x45228,0
ortp-message-ms_filter_unlink: MSEqualizer:0x45228,0-->MSVolume:0x45138,0
ortp-message-ms_filter_unlink: MSVolume:0x45138,0-->MSAlsaWrite:0x44ed0,0
ortp-message-Audio MSTicker thread exiting
Call ended 

2010/6/22 alex z <address@hidden>

Hi Harishkumar,

Thanks for your help. I have disabled speex codec in ~/.linphonerc, and I can see rtp packets are sending at PCMA format by using wireshark.
But wrong timestamp is still really high. And no sound.
I check cpu uage of ARM board is really low.
Any other tips?


2010/6/21 Harishkumar V <address@hidden>


check that u have enabled speex codec, u have to disable it.
I faced the problem in similar manner, but after disabling speex codec, it worked fine.
because, in arm, speex codec takes too much mips, thats what i faced, i do not know abt ur situation.
I used pcm-u and pcm-a codecs.

On Mon, Jun 21, 2010 at 3:52 PM, alex z <address@hidden> wrote:
Hi All,

I just ported linphone to my arm board, and call it from PC (ubuntu), and found a strange issue:

1) Directly call from PC, No sound. 
Audio Streaming: Micphone(ARM BOARD) --> ALSA(ARM BOARD) --> Linphone(ARM BOARD) --> Linphone (PC) -->Earphone(PC). 

2) In ARM BOARD, Use command "soundcard use files", and then play a wav file, I can hear sound on earphone of PC.
Audio Streaming: Wav file(ARM BOARD) -> Linphone(ARM BOARD) --> Linphone (PC) --> Earphone(PC)

3) In PC, use command "soundcard use files" and then record a wav file. after end call, I can hear sound from wav file, this sound is really from Micphone of ARM BOARD.
Audio Streaming: Micphone(ARM BOARD) --> ALSA(ARM BOARD) -> Linphone(ARM BOARD) --> Linphone (PC) --> Record to a wav file.

and use wireshark to capture these voip call sessions, 
In case 1), have rtp packets from ARM board, but no sound In RTP Player of wireshark.
In case 3), have rtp packets from ARM board, and found sound in RTP Player of wireshark. But I found that, Drop by Jitter Buff is hight to 24.2%.

Anyone can help me? Any tips? Thanks!


Linphone-developers mailing list

Thanks and Regards,
Harish Kumar. V

Thanks and Regards,
Harish Kumar. V

Thanks and Regards,
Harish Kumar. V

reply via email to

[Prev in Thread] Current Thread [Next in Thread]