[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linux-uvc-devel] [Linphone-developers] 064e:a101 Suyin Corp. Cam in

From: Simon Morlat
Subject: Re: [Linux-uvc-devel] [Linphone-developers] 064e:a101 Suyin Corp. Cam in Acer Notebook - Still no image on Linphone 2.0.1
Date: Tue, 26 Feb 2008 16:05:53 +0100
User-agent: KMail/1.9.7

Hi Conrad,

My only hypothesis concerning this problem is that the linux usb stack does 
not like that linphone makes call to it using 2 different threads (through 
the uvc driver). I plan to rework the grabbing component to get only one 
thread talking with the driver.
I experience also very strange problem with that uvc driver with pictures 
being splitted or very unstable and ffmpeg complaning of corrupted mjpeg 
bitstream. I think all this is related to the threading design used in 
Concerning windows vista, I know there are several problems but unfortunately 
I could never have a try myself. A friend of mine is going to give me its PC 
with vista installed to get a chance to solve all those problems.


Le Friday 01 February 2008 19:02:45 Conrad Beckert, vous avez écrit :
> Hi Folks,
> ... recently I had some time to install Linphone 2.0.1 on my
> abovementioned notebook.
> Unfortunately the problem with the camera persists. I got a black screen
> and an error message somewhat different then in earlier tests:
> ortp-message-v4l_start: open, fd=15
> ortp-message-v4lv2: V4L2_PIX_FMT_YUYV choosen
> ortp-message-Device is a video4linux V2 one.
> ortp-message-ms_filter_link: MSV4l:0x821aac0,0-->MSPixConv:0x8214d58,0
> ortp-message-ms_filter_link:
> MSPixConv:0x8214d58,0-->MSVideoOut:0x81e4b88,0
> ortp-message-v4l_thread starting
> ortp-message-Using yuv overlay.
> ortp-message-YUV overlay using hardware acceleration.
> ortp-error-VIDIOC_STREAMON failed: Protocol error
> ortp-message-eXosip: Reseting timer to 15s before waking up!
> ortp-message-v4l thread has joined.
> ortp-message-v4l fd 15 closed
> ortp-message-ms_filter_unlink: MSV4l:0x821aac0,0-->MSPixConv:0x8214d58,0
> ortp-message-ms_filter_unlink:
> MSPixConv:0x8214d58,0-->MSVideoOut:0x81e4b88,0
> ortp-message-MSTicker thread exiting
> ortp-message-Release a terminated transaction
> ortp-message-Release a terminated transaction
> ortp-message-free transaction ressource 1 1351328649
> ortp-message-free nict ressource
> The camera itself works on Linux. Strangely - Kopete, of which the (not
> so useful) webcam functionality has always been a source of crashes or
> even system freezes - gets be a bright, clear picture. I can even adjust
> brightness, contrast, color etc. there.
> What is wrong with Linphone?
> I then tried the latest Linphone version on Windows Vista - with the
> same result.
> What's wrong?
> Thank you for help
> Conrad
> _______________________________________________
> Linphone-developers mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]