[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libunwind-devel] [PATCH] Add an option to have start_ip_offset be r

From: Arun Sharma
Subject: Re: [Libunwind-devel] [PATCH] Add an option to have start_ip_offset be relative to start_ip
Date: Tue, 6 Oct 2015 10:20:48 -0700

On Sun, Oct 4, 2015 at 10:30 PM, Keno Fischer
<address@hidden> wrote:
> Bump, does this patch look reasonable?

Yes - looks reasonable to me. Wonder why it wasn't a problem for other
LLVM JIT users (eg: pyston?).

> unw_dyn_remote_table_t, but

I think you meant to say "Like REMOTE_TABLE, but ..".

Perhaps call it IP_OFFSET instead of TABLE2?

+  if (di->format == UNW_INFO_FORMAT_REMOTE_TABLE ||
+      di->format == UNW_INFO_FORMAT_REMOTE_TABLE2)

Could you wrap this in is_remote_table()?

> +    ip_base = segbase;

Rename it something neutral that works for both the segbase and ip_base cases?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]