[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] blank screen with libreboot on x200

From: Tudor SUCIU
Subject: Re: [Libreboot] blank screen with libreboot on x200
Date: Fri, 8 Jul 2016 02:14:46 +0200


So I bought a new x200 motherboard to replace the broken one and it didn't
seem to work. It was because of the ram.
Points to remember - differences to documentation:
1. flashrom speed 512 does not work for me - 1024 and 2048 work
2. Beaglebone Black with usb connection is not able to power the spi chip
(needed a Raspberry pi)
    Beaglebone Black with 5V round connection to a 4A source works just
3. The Beaglebone Black does not work as documented anymore, you need an
old wheezy image.
    There is a very badly referenced on Google image:
    Thanks irc for advice about it
4. Libreboot is really picky about ram. Out of 5 dimms there are many
combinations that don't work.
    If you see a black screen there are big chances it is it!
5. Great care is needed when programming libreboot, I don't even know how I
broke one mainboard
    (probably a short-circuit, I changed the connector type now)
6. Full disk encryption documentation doesn't work anymore! I have no
solution yet.
    I tried putting /boot on a usb drive, but there are a lot of steps
after that:
    copy /boor/* to encrypted /
    change in grub the guid of the disk (not tested yet)
    take out of /etc/fstab the /boot (forgot about it, unbootable linux)

If somebody has a solution for 5 i'll try to follow it.

On Thu, Jun 30, 2016 at 1:36 AM, Tudor SUCIU <address@hidden> wrote:

> Hello,
> The older x200 worked from first try. I had to use 1024 speed, not 512.
> The newer x200 seems broken now, it doesn't boot anymore even with lenovo
> bios.
> There is spi activity with lenovo bios, if somebody wants to debug it you
> have to tell me quickly,
> before I send the laptop to a repair shop. I can give complete traces,
> there is quite a lot of noise at 33mhz but it should be doable.
> I'll try to attach the bios if somebody finds it usefull.
> I am certain that libreboot didn't work at any point on the new x200, I
> managed to have lenovo bios->libre boot->... several times before braking
> it.
> It might be just a fuse, the southbridge is not warm anymore, but spi has
> 3,3v.
> On Sun, Jun 26, 2016 at 7:01 PM, Tudor SUCIU <address@hidden>
> wrote:
>> Hello,
>> I managed to trace what is happening on the X200 that I try to use with
>> libreboot.
>> It reads from spi the address 0x000200. In the libreboot image there is
>> 0x7D at this address.
>> In the original rom there is 0x78.
>> I searched with advanced trigger but there is no second chip select edge.
>> Is there an obvious reason for this problem?
>> On Sat, Jun 25, 2016 at 11:40 PM, Tudor SUCIU <address@hidden>
>> wrote:
>>> Hello,
>>> I tried the EHCI debug with the recommended beta x200 image.
>>> I suspect it's not a screen issue, but a ram issue.
>>> I don't get any EHCI Debug output. With the kernel parameter
>>> "earlyprintk=dbgp,keep" and original bios I get the printk output so the
>>> beaglebone black setup is buggy but working.
>>> Are there any recommended parameters in order to debug ram issues?
>>> I have 4 ram modules of 4 types. I have read that libreboot should be
>>> able to use a single module.
>>> On Thu, Jun 16, 2016 at 6:40 AM, Iru Cai <address@hidden> wrote:
>>>> On Thu, Jun 16, 2016 at 2:50 AM, Tudor SUCIU <address@hidden>
>>>> wrote:
>>>>> Hello,
>>>>> I used the image 20150518 x200_8mb_usqwerty_vesafb.rom on a x200 type
>>>>> 7459-KM3.
>>>>> The pc starts normally, but the screen is always black. The vga output
>>>>> does
>>>>> not work either.
>>>>> There are some errors while writing/reading the images so the process
>>>>> is
>>>>> pretty slow.
>>>>> The system has proprietary bios again now. Are there any pieces of info
>>>>> that I should provide to help tracking the problem?
>>>> You can connect a EHCI debug dongle to the X200 and get some debug
>>>> output.
>>>>> Is there a different image(text mode) that I should try?
>>>>> Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]