[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Bricked my c201

From: fatih . balli
Subject: Re: [Libreboot] Bricked my c201
Date: Wed, 29 Jun 2016 03:26:29 +0200
User-agent: Internet Messaging Program (IMP) H3 (4.3.11)


I had a similar problem with bricking my c201 device yesterday. I am not sure if it is completely related, but the case seemed very close.

After installing archlinux on sd card, I dared to remove the internal 16gb /dev/mmcblk0 completely so I can migrate my installation to it. I had set


which worked fine. Then I happen to disable developer mode on libreboot, which failed booting anyhting. I was asking myself is it not too loose by means of security to let any device bootable by just Ctrl+D, Ctrl+U. I was so wrong, I reenabled the developer mode and my booting parameters became:

dev_boot_signed_only=0 (which is OK)
dev_boot_usb=0 (can't boot usb)

Shortly, I locked myself out by not having internal kernel to boot, and having disabled usb-booting. The first impression was I had to remove spi flash chip, however libreboot warning message indicated there should be recovery image. I prepared the recovery image with Google's guide and booted as recovery USB.

If you have low battery, the device shuts itself without giving reason, so I thought there was some problem with recovery because of it is not original coreboot but libreboot etc. I pluged DC power and it continued recovery.

At this point use Ctrl + Alt + F3 to see detailed log. If you wait long enough you will realize that there is script and it complains that the firmware version is not "veyron-speedy" but "libreboot-experimental". I tried to find the code (hoping it was free), but failed to do so. Nevertheless, the logs clearly indicated that the internal drive partitions are being created, written correctly with no complaint etc... But the final result is this "an unexpected error occurred". And it does not work obviously.

I restarted recovery. Opened the active log with Ctrl + Alt + F3, waited carefully until partitions are being created, and at the very moment it started writing partition 3 (it starts with 12nd partition and comes down to 1st one in reverse order) I held the power button down for ~10 secs and cut the power. I started the laptop and there it is: running CrOS. I was able to return the initial setting thankfully.

So I think if you can run the recovery image, you have high probability of recovering your device even without opening it. Hope it helps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]