[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Bricked my c201

From: Albin
Subject: Re: [Libreboot] Bricked my c201
Date: Wed, 29 Jun 2016 21:01:23 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.1.0

Hi again Fatih,

Thank you for the encouragement.  I'm trying over and over but can't
make it work.

Den 2016-06-29 kl. 17:27, skrev address@hidden:
> Hi Albin,
> I wiped my internal flash again, and tried this one more time. At the
> first try I failed. (at this trial I started to press power button
> constantly as soon as i see "Installing partition 3 to /dev/mmcblk0").

Do you mean that you hold down the power button until it shuts down or
is there a way to do it quicker?

> At the second time I waited partition 3 to finish and tried again and it
> worked. (by the time laptop powered down, the last console message was
> "Installing partition 2 to ...") I think you are right that there is a
> somehow precise timing on that, but given it worked in few trials; I
> suggest you try again if possible.

I find it difficult to time the hard shutdown so that the console
message is "Installing partition 2...", because as soon as it finishes
with 3 it goes over partition 2 so quickly that I don't have time to
power off.  Whenever I try to power off during the partition 3 process
the last console message is also "Installing partition 3...", and then
it never works; after reboot I just return to the recovery mode screen
with the message "Please insert an external recovery media."

By the way, after the "ChromeosChrootPostInst" is see the following message:

Touch(/mnt/stateful_partition/.install_completed) FAILED

...just before "Starting firmware updater".  So maybe something else
that's important fails before the firmware-version check?

> You might wonder why I tried at partition 3. cgpt show /dev/mmcblk0
> gives the partition layout, and I thought I needed a reliable kernel (at
> parititon 4) and rootfs (at partition 5).

The layout flashes by very quickly so it's hard to see, but I believe
that also partition 3 contains the root file system.

> When you let the installation complete, it realizes that firmware
> version is not "veyron-speedy" and reverts things back.

Yep, I saw that. In my case the boot and EC firmware versions are:

RO: libreboot-r20150518fix-627-ge72f577, ACT:
libreboot-r20150518fix-627-ge72f577, EC: speedy_v1.1.2697-faafaa5

Maybe it works differently for me because of an older boot firmware
version?  Or maybe it's the file systems on my device that have become
corrupted and that's why I fail to recover like you have.  It's very
hard to know what's going on here.  If I let the recovery program
continue it starts a file system check and then freezes at this point:

[ 253.441447] EXT4-fs (loop2): mounted filesystem without journal. Opts:

Also, do you see this message after "installing partition 11..."?


> Hard resetting
> machine lets me disable that verification -- and since we only need
> internal memory to have signed bootable kernel it works.

Why shouldn't it need a complete OS to boot?

> I hope it helps you as well. I have come to rely very much on this
> procedure, I wiped my internal device without hesitation :)
> Recovery file:
> chromeos_8172.60.0_veyron-speedy_recovery_stable-channel_speedy-mp-v3.bin
> md5sum: ae26e41c72ee6c76f821e9356fe72cd7
> Cheers,

Thanks!  There were a lot of questions in this email.  I don't expect
you to answer all of them; it's just questions that pop up in my head
when I try this thing over and over again.



> Quoting Albin <address@hidden>:
>> Hi Fatih,
>> I was able to run the recovery image and open the detail log with Ctrl +
>> Alt + F3 as you explained.  Unfortunately, it doesn't work for me to
>> reinstall ChromeOS by either letting the recovery process finish (up to
>> verification, where it fails like you explain) or by interrupting it by
>> powering down when writing to a) partition 3, b) to partition 1 or c) to
>> the "stateful" partition.
>> Maybe this is about very precise timing?  Did you try to power down at
>> some other points in the recovery process and that didn't work, or did
>> you just randomly try it at the partition 3 stage and it happened to
>> work?
>> I'm glad that you were able to recover and sent this email to the list,
>> even if I haven't managed to reset my own computer.
>> Cheers,
>> Albin
>> Den 2016-06-29 kl. 03:26, skrev address@hidden:
>>> Hello,
>>> I had a similar problem with bricking my c201 device yesterday. I am not
>>> sure if it is completely related, but the case seemed very close.
>>> After installing archlinux on sd card, I dared to remove the internal
>>> 16gb /dev/mmcblk0 completely so I can migrate my installation to it. I
>>> had set
>>> dev_default_boot=usb
>>> dev_boot_signed_only=0
>>> dev_boot_usb=1
>>> which worked fine. Then I happen to disable developer mode on libreboot,
>>> which failed booting anyhting. I was asking myself is it not too loose
>>> by means of security to let any device bootable by just Ctrl+D, Ctrl+U.
>>> I was so wrong, I reenabled the developer mode and my booting parameters
>>> became:
>>> dev_default_boot=internal
>>> dev_boot_signed_only=0 (which is OK)
>>> dev_boot_usb=0 (can't boot usb)
>>> Shortly, I locked myself out by not having internal kernel to boot, and
>>> having disabled usb-booting. The first impression was I had to remove
>>> spi flash chip, however libreboot warning message indicated there should
>>> be recovery image. I prepared the recovery image with Google's guide and
>>> booted as recovery USB.
>>> If you have low battery, the device shuts itself without giving reason,
>>> so I thought there was some problem with recovery because of it is not
>>> original coreboot but libreboot etc. I pluged DC power and it continued
>>> recovery.
>>> At this point use Ctrl + Alt + F3 to see detailed log. If you wait long
>>> enough you will realize that there is script and it
>>> complains that the firmware version is not "veyron-speedy" but
>>> "libreboot-experimental". I tried to find the code (hoping it was free),
>>> but failed to do so. Nevertheless, the logs clearly indicated that the
>>> internal drive partitions are being created, written correctly with no
>>> complaint etc... But the final result is this "an unexpected error
>>> occurred". And it does not work obviously.
>>> I restarted recovery. Opened the active log with Ctrl + Alt + F3, waited
>>> carefully until partitions are being created, and at the very moment it
>>> started writing partition 3 (it starts with 12nd partition and comes
>>> down to 1st one in reverse order) I held the power button down for ~10
>>> secs and cut the power. I started the laptop and there it is: running
>>> CrOS. I was able to return the initial setting thankfully.
>>> So I think if you can run the recovery image, you have high probability
>>> of recovering your device even without opening it. Hope it helps.
>>> -Fatih

reply via email to

[Prev in Thread] Current Thread [Next in Thread]