[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Libreboot] I found a workaround to cryptomount problem with DVD drive

From: Fil
Subject: [Libreboot] I found a workaround to cryptomount problem with DVD drive
Date: Wed, 27 Apr 2016 21:20:42 +0200

Hi everyone,

my name's Fil and I just joined this list.
I just wanted to tell you all, I have found a workaround for the problem
described at

Last week I received from Francis (at last!) my libreboot-powered
Minifree T400, and I installed Trisquel with full disk encryption.
As stated in the page linked above, I had some issues while mounting the
encrypted volume using cryptomount -a in GRUB.
The problem was indeed the DVD drive. Removing it while booting worked
around the problem, but removing it before every startup is a bit of a
hassle, so...
I had a little bit of think-about-it and.. just changing the cryptomount
command in grub.cfg solved the issue!!!
I changed "cryptomount -a" to "cryptomount -u <disk UUID>", flashed the
modded ROM... et voila! Now the encrypted volume gets mounted correctly,
even with the DVD drive in place.

I think the problem was that cryptomount -a tries to decrypt ALL
volumes, so maybe it was searching for encrypted volumes on the DVD,
thus timing out.

I already told Francis about this, but I thought to share this
workaround with the community, hoping It can help someone!

Best wishes,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]