[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] I found a workaround to cryptomount problem with DVD dri

From: Ministry of Freedom
Subject: Re: [Libreboot] I found a workaround to cryptomount problem with DVD drive
Date: Thu, 28 Apr 2016 11:47:16 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.8.0

Hash: SHA1

thanks. i added a note about this to the guides

Op 28/04/16 om 08:12 schreef Daniel Tarrero:
> ey! that got all sense 8) everybody is kung-fu fighting this
> morning =)
> seem that, given the dvd is attached, the device mapping might
> change and mess up grub if its configured to point to "the old
> style" namming convention (something like hd(0,0) or hd(1,0) i
> think). This namming can change when you (re)move hardware.
> As you point us, using the suuuuuuuuuuuupper uuids (where the units
> are mapped given a 'label' within the same drive, so it always get
> the same name regardless it's position, bus, its removed or moved
> to another machine. Something like 
> 129436932769-12396128376128-12973651267 that i can remember ^^
> nice to learn it solves this issue 8) D
> On Wed, Apr 27, 2016 at 09:20:42PM +0200, Fil wrote:
>> Hi everyone,
>> my name's Fil and I just joined this list. I just wanted to tell
>> you all, I have found a workaround for the problem described at 
Last week I received from Francis (at last!) my libreboot-powered
>> Minifree T400, and I installed Trisquel with full disk
>> encryption. As stated in the page linked above, I had some issues
>> while mounting the encrypted volume using cryptomount -a in
>> GRUB. The problem was indeed the DVD drive. Removing it while
>> booting worked around the problem, but removing it before every
>> startup is a bit of a hassle, so... I had a little bit of
>> think-about-it and.. just changing the cryptomount command in
>> grub.cfg solved the issue!!! I changed "cryptomount -a" to
>> "cryptomount -u <disk UUID>", flashed the modded ROM... et voila!
>> Now the encrypted volume gets mounted correctly, even with the
>> DVD drive in place.
>> I think the problem was that cryptomount -a tries to decrypt ALL 
>> volumes, so maybe it was searching for encrypted volumes on the
>> DVD, thus timing out.
>> I already told Francis about this, but I thought to share this 
>> workaround with the community, hoping It can help someone!
>> Best wishes,
>> Fil

- -- 
Libreboot developer
Freenode IRC nick (#libreboot): vimuser

Use free software. Free as in freedom.

Use a free operating system, GNU/Linux.

Use a free BIOS.

Support freedom. Join the Free Software Foundation.

Minifree Ltd, trading as Ministry of Freedom | Registered in England,
No. 9361826 | VAT No. GB202190462
Registered Office: 19 Hilton Road, Canvey Island, Essex SS8 9QA, UK |

Version: GnuPG v2.0.22 (GNU/Linux)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]