[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] BBB kernel

From: IngeGNUe
Subject: Re: [Libreboot] BBB kernel
Date: Tue, 15 Mar 2016 20:40:52 -0400

On 03/15/16 06:36, dch wrote:
> It sort-of worked, but another isue arose. I got spidev working with the 
> compiled .dtbo, although I had to 
> `echo BB-SPI0-01 > /sys/devices/platform/bone_capemgr/slots` 
> instead of 
> `echo BB-SPI0-01 > /sys/devices/bone_capemgr.*/slots`
> which I found strange but didn't give thought to. 
> However trying to use /dev/spidev1.0 with flashrom on -r or -w lead to me 
> getting a warning that flashrom
> had been stuck for 120 deconds which would never go away (fortunately only 
> happened during reads, which 
> meant it could be "safely" force rebooted mid-process). I then tried to updae 
> the debian kernel on my BBB
> to 4.5.0-rc7-bone3 and then spidev stopped working, again.
> Any ideas? On either how to troubleshoot what's wrong or how to get a working 
> kernel ver?
> Thanks

Interesting! :o

Just make sure you get DEAD BEEF BAAD FOOD in spidev_test before moving
on to flashrom, to ensure it's working correctly. When I started having
trouble again, I was getting *random* outputs from spidev_test. Even
though the chip was detected, something was still misbehaving.

The author of that blog alludes to using Ubuntu. I've been wondering if
there's a reason for that, and if it would be worth spending some time
installing a different distro, where the desired packages are available
and work. I haven't looked at alternatives but it does seem to matter a
whole lot specifically what version the distro is, along with these
packages, and whether a given package is supported then.

Are you running Debian wheezy? Spidev should work...

HOWEVER, the flashrom package does not appear to be available for ARM
until Debian Stretch:

>• [58]stretch (testing) (electronics): Identify, read, write, erase,
>and verify BIOS/ROM/flash >chips

>    0.9.9~rc1+r1946-1: amd64 arm64 armel armhf i386 mips mipsel
>powerpc ppc64el >s390x

>  • [59]sid (unstable) (electronics): Identify, read, write, erase,
>and verify BIOS/ROM/flash >chips

>    0.9.9+r1954-1: alpha amd64 arm64 armel armhf hppa i386
>kfreebsd-amd64 kfreebsd-i386 m68k mips mipsel powerpc ppc64 ppc64el
>s390x sh4 sparc64 x32

Maybe it's fine to compile from source, it's just one of those lingering
thoughts I had while doing this :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]