[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] BBB kernel

From: dch
Subject: Re: [Libreboot] BBB kernel
Date: Tue, 15 Mar 2016 10:36:33 +0000
User-agent: Mutt/1.5.23 (2014-03-12)

It sort-of worked, but another isue arose. I got spidev working with the 
compiled .dtbo, although I had to 
`echo BB-SPI0-01 > /sys/devices/platform/bone_capemgr/slots` 
instead of 
`echo BB-SPI0-01 > /sys/devices/bone_capemgr.*/slots`
which I found strange but didn't give thought to. 
However trying to use /dev/spidev1.0 with flashrom on -r or -w lead to me 
getting a warning that flashrom
had been stuck for 120 deconds which would never go away (fortunately only 
happened during reads, which 
meant it could be "safely" force rebooted mid-process). I then tried to updae 
the debian kernel on my BBB
to 4.5.0-rc7-bone3 and then spidev stopped working, again.

Any ideas? On either how to troubleshoot what's wrong or how to get a working 
kernel ver?


On Sat, Mar 12, 2016 at 07:16:08PM -0500, IngeGNUe wrote:
> Recompiling the kernel won't be necessary -- try this:
> Relevant part:
> "I have a trick that is not mentioned in the wiki to save you from the
> agony of re-compiling the freaking kernel just to get the spidev
> working. Instead of defining compatible = "linux,spidev";, in the dts
> file, you can define compatible = "rohm,dh2228fv";."
> Let me know if you have any questions on getting this to work. It worked
> for a while but when I pulled everything apart and tried again, and I
> got stuck. Nonetheless I have committed the steps to memory at this point :P
> On 03/12/16 14:06, dch wrote:
> > Hello,
> > 
> > I can't seem to get spidev working on my Beaglebone black, and I think it's 
> > an issue with the kernel. 
> > Can anyone send me a compiled kernel where SPI works, and/or a kernel 
> > .config?
> > 
> > Thanks
> > 
> > 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]