[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

booting viengoos with GRUB2 v. 1.99~rc1

From: Andrew Engelbrecht
Subject: booting viengoos with GRUB2 v. 1.99~rc1
Date: Wed, 6 Apr 2011 18:43:54 -0400

Has anyone gotten viengoos to boot using GRUB2 v. 1.99~rc1? I get the
following errors in qemu when try to boot Viengoos:

error: invalid offset in section header.
error: you need to load the multiboot kernel first

Looking at the date of the patch recommended for GRUB at
http://www.gnu.org/software/hurd/microkernel/viengoos/building.html ,
I figured that v. 1.97 would be the closest tried and tested version
of GRUB and therefore might work with viengoos. Unfortunately, v1.97,
v1.97.1, v1.97.2 and v1.98 don't cross-compile on my PPC computer.
Here are the errors I get when compiling v1.97:

gcc -Iutil/i386/pc -I../util/i386/pc -I. -I./include -I../include
-Wall -W 
grub/i386-pc | sed 's&^&i386-pc-linux-gnu-&'`\" -g -O2 -DGRUB_UTIL=1
-MD -c -o grub_setup-util_i386_pc_grub_setup.o
../util/i386/pc/grub-setup.c:38: error: initializer element is not constant
../util/i386/pc/grub-setup.c:38: error: (near initialization for
../util/i386/pc/grub-setup.c:38: error: braced-group within expression
allowed only inside a function
../util/i386/pc/grub-setup.c:38: error: braced-group within expression
allowed only inside a function
../util/i386/pc/grub-setup.c:38: warning: missing initializer
../util/i386/pc/grub-setup.c:38: warning: (near initialization for
make: *** [grub_setup-util_i386_pc_grub_setup.o] Error 1

It looks like I'm not the only one running into similar problems on a
PPC machine:


I figure going back to 1.96 or older would be going back too far.
Compatibility with PPC is bound to be worse in the past, as they have
been adding support for booting PPC over time. So building the tools
on PPC will probably be fruitless as well, which is where the above
failures have been occurring. I also tried using the sources for
v1.98, provided by Debian with patches and all, but I still ran into
the same error. I know the cross-compiler's not at fault, since it's
the regular gcc that's being used above.

Another thing is that when I start qemu, I get an "error: file not
found" error after a "Welcome to GRUB" message, but before the GRUB
menu. Since the "Viengoos" option loads, I am assuming that my config
file was loaded. In the off chance that my grub.cfg is the problem,
i've attached it. Also, I 've attached the diff file that I used to
get v1.99~rc1 to load the config file with the following command:

bin/i386-pc-linux-gnu-grub-mkrescue -o boot.img
--configpart='(hd0,msdos1)' --modules='*.mod'

I guess that was mostly a rant, but if anyone has any tips, tries
booting viengoos using version 1.99~rc1 of GRUB2 themselves, or sends
a patched build of v1.97 my way, that would greatly be appreciated.


Attachment: grub.cfg
Description: Binary data

Attachment: config_partition.diff
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]