[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Booting Hurd-L4 under qemu

From: Rian Hunter
Subject: Re: Booting Hurd-L4 under qemu
Date: Mon, 01 Nov 2004 19:33:39 -0500
User-agent: Mozilla Thunderbird 0.8 (Macintosh/20040913)

Sam Mason wrote:

Marcus Brinkmann wrote:
I use qemu.

Just tried qemu but haven't had as much luck as with bochs.  I've
tried both the latest relased and CVS versions of qemu with the disk
image I was using with bochs to no avail.  P2-mate (on IRC)
reccommended trying compiling Pistachio for an i586 processor.  It
does a little better now and Pistachio boots, but Sigma0 dies with
"s0: no page-size mask" - I'm guessing this comes from Sigma0 as the
binary contains that string!  The IP also verifies this; eip=00041344
when it dies and I get this boot message:

 Sigma0: Low 0x40000, High 0x483a0, IP 0x41950, SP 0x0

Any ideas on what I've got wrong?
Hmm, well first the stack pointer is (SP) is 0x0, and that isn't exactly right. Also that error comes only if the PageSizeMask field of the KIP is empty and it really really shouldn't be. How are you booting? Try a standard L4 boot just to see if your kernel and userland apps were compiled correctly, in grub:

kernel /path/kickstart
module /path/ia32-kernel
module /path/sigma0
module /path/grabmem


What I would do is set the debug flag in the sigma0 source: (Line 49 in sigma0.cc, set verbose to > 0), make a clean build, then seeing what sigma0 says about its KIP when it is booting before it gets to init_mempool(). If that gives you no luck, also check the code the is filing the KIP in the kernel. If all else fails, get version 0.4 of Pistachio, do a clean build for the Pentium (not 2/3/4) processor and try that. Good luck!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]