[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] Using "rootsh" with jailkit

From: Olivier Sessink
Subject: Re: [Jailkit-users] Using "rootsh" with jailkit
Date: Wed, 29 Apr 2009 21:42:50 +0200
User-agent: Thunderbird (X11/20090318)

Charley Marsh wrote:
> Thank you for responding so quickly! I ran strace on the "rootsh"
> program, and it seems that all of the necessary files are in place. I
> did an strace attached to the user who was logged in to the jail, but
> the egrep search for (access|open) did not return any results. The
> strace of the user had a lot of information in it but I am not sure what
> I am looking at. I am wondering if I have done something wrong while
> setting up the jail. When I run jk_list, here is the output:
> Pid    User   Jail         Command                                        
> 15428  nobody /etc/jailkit /usr/sbin/jk_socketdI4Qr: (deleted)
> 16055  nobody /etc/jailkit /usr/sbin/jk_socketdI4Qr: (deleted)
> 16082  nobody /etc/jailkit /usr/sbin/jk_socketdI4Qr: (deleted)
> My jail is located at /xjail currently but that directory does not show
> up, and neither does the user account who is logged in to the jail. Do
> you know what could be causing that?

jk_list should only show an account that is jailed with jk_chrootsh if
that account is logged on. You explained that rootsh failed, so the user
is not logged on, right?

Perhaps try if jk_list shows the user when you use bash?


b.t.w. please post to the list, the answers may be useful for other
people too.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]