[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] I can't jail mldonkey

From: Olivier Sessink
Subject: Re: [Jailkit-users] I can't jail mldonkey
Date: Tue, 4 Nov 2008 09:49:19 +0100 (CET)
User-agent: SquirrelMail/1.4.13

> I've been trying the jailkit method of jailing mlnet and I follow the
> instructions as best I can
> (http://mldonkey.sourceforge.net/Chroot#JailKit) and when I try to do:
> su mldonkey
> I get:
> jk_chrootsh[4185]: abort, effective user ID is not 0, possibly jk_chrootsh
> is not setuid root

can you post the output of 'ls -l /usr/sbin/jk_chrootsh' ?

> ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or
> directory

that is not a serious issue.

> I copy the file manually and tried jk_cp but no go.
> I've tried:
> jk_chrootlaunch -p /var/run/mlnet.pid -u mldonkey -g mldonkey -j
> /home/jail -x /usr/bin/mlnet
> But:
> 2008/11/04 06:56:37 [cO] Exception chdir failed on /home/jail: No such
> file or directory trying to chroot /home/jail

does the directory '/home/jail' exist? can you post the output of 'ls -al
/home/jail' ?

> I'm sorry if I screw this up a bit, I've never posted to one of these
> lists before.  I just don't know where else to ask this question.

this place is exactly meant for these questions ;-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]