[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] I can't jail mldonkey

From: some one
Subject: [Jailkit-users] I can't jail mldonkey
Date: Tue, 4 Nov 2008 02:29:37 -0500

I've been trying the jailkit method of jailing mlnet and I follow the 
instructions as best I can (http://mldonkey.sourceforge.net/Chroot#JailKit) and 
when I try to do:

su mldonkey

I get:

jk_chrootsh[4185]: abort, effective user ID is not 0, possibly jk_chrootsh is 
not setuid root

In /var/log/syslog 

When I do:

jk_init -v -j /home/jail basicshell mldonkey

I get this:

ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or 

I copy the file manually and tried jk_cp but no go.

I've tried:

jk_chrootlaunch -p /var/run/mlnet.pid -u mldonkey -g mldonkey -j /home/jail -x 


2008/11/04 06:56:37 [cO] Exception chdir failed on /home/jail: No such file or 
directory trying to chroot /home/jail

In this case I have to export MLDONKEY_CHROOT=/home/jail and 
/home/jail/./home/mldonkey or it attempts to start, but fails, in my /root 

I'm using slackware 12.1 with a custom kernel on an AMD Athlon64x2 
3800 w/ foxconn NF4UK8AA nforce4 chipset.  Maybe there's a modules I'm missing? 
 I really have no clue as to how to go about solving this problem.

I'm sorry if I screw this up a bit, I've never posted to one of these lists 
before.  I just don't know where else to ask this question.

Free Email at http://www.MailPuppy.com
- Fraud Warning:  Never accept foreign checks/money orders

reply via email to

[Prev in Thread] Current Thread [Next in Thread]