[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] Suse 64bit SFTP problem

From: Olivier Sessink
Subject: Re: [Jailkit-users] Suse 64bit SFTP problem
Date: Wed, 14 Mar 2007 08:07:06 +0100
User-agent: Icedove (X11/20061220)

Jere Retzer wrote:
> Thanks, Olivier
> Sequence of actions below might have something useful - bottom line
> is success. Thank you very much. Question: can the same user sftp
> from multiple machines at the same time or would they be locked out?

I have no idea, ask the openssh developers. I would guess it is possible.

> Worked through the issue of the user /lib64/libnss* files (which were
> not reported by ldd) reported by Norbert on March 6 (on RHEL4)

the libnss_* files are plugins, and because of that they are not found
by ldd. The section [uidbasics] has them in /lib where they are on
normal x86 distributions.

> The
> files are not exactly the same between Opensuse 10.2, which I am
> using and RHEL that Norbert is using. It seems to me that one
> potential trap involves copying /lib/libnss* and/or /usr/lib/libnss*
> instead of /lib64/libnss* and usr/lib64/libnss*  As I looked over the
> files in my jail directories it looked to me like perhaps some of the
> wrong files were copied (maybe when initializing with jk_lsh?)

probably yes, probably jk_init has still all the /lib defaults in its
config file and not /lib64

> so my
> solution was to cp -f -v libnss* from the /lib64 and /usr/lib64 to
> the associated jail directory and now it works.

`jk_cp /myjail /lib64/libnss*` would be possible too.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]