[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] Re: Hi problem with using jail

From: Olivier Sessink
Subject: [Jailkit-users] Re: Hi problem with using jail
Date: Tue, 21 Nov 2006 08:00:44 +0100
User-agent: Thunderbird (X11/20060812)

Maverick wrote:
> Hi 
> i have successful  install jailkit in OpenBSD 4.0 how ever i try to follow 
> the 
> example from the hompage chroot shell 
> so i run these command 
> mkdir /home/jail
> chown root:wheel /home/jail <- This is the only different command that i have 
> used
> jk_init -v /home/jail basicshell
> jk_init -v /home/jail editors
> jk_init -v /home/jail extendedshell
> jk_init -v /home/jail netutils
> jk_init -v /home/jail ssh
> jk_init -v /home/jail sftp
> jk_init -v /home/jail scp

jk_init.ini is designed for a Debian system, there is no openbsd format
of that file yet (openbsd has a lot of files in different locations). So
you'll have to use jk_cp to copy the files.

> To make sure i tried jk_cp and that is what happened
> # jk_cp /home/jail/usr/bin/ /usr/sbin/jk_lsh

jk_cp /home/jail /usr/sbin/jk_lsh
is the correct syntax

> ldd returns non existing library exe
> ldd returns non existing library rlib
> ldd returns non existing library rtld

what is the output of `ldd /usr/sbin/jk_lsh`


b.t.w. please post questions like these to the list so other people know
what is going on too. Posted to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]