[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] jk_lsh.ini -- Primary / Secondary groups

From: Scott Ruckh
Subject: Re: [Jailkit-users] jk_lsh.ini -- Primary / Secondary groups
Date: Sun, 15 Oct 2006 16:50:21 -0700 (MST)
User-agent: SquirrelMail/1.4.8-2.el4.centos4

This is what you said Olivier Sessink
> Scott Ruckh wrote:
>> Here is the the jk_lsh.ini file:
>> executables = /usr/bin/scp, /usr/libexec/openssh/sftp-server
>> paths = /usr/bin/, /usr/lib, /usr/libexec/openssh
>> allow_word_expansion = 1
>> [group jkbash]
>> executables = /usr/bin/bash, /usr/bin/scp,
>> /usr/libexec/openssh/sftp-server
>> paths = /usr/bin/, /usr/lib, /usr/libexec/openssh
>> allow_word_expansion = 1
>> [group jksftp]
>> executables = /usr/bin/scp, /usr/libexec/openssh/sftp-server
>> paths = /usr/bin, /usr/libexec/openssh
>> allow_word_expansion = 1
> hmm funny, if I copy and paste this into my jk_lsh.ini the DEFAULT
> section is correctly used.
> Which version of jailkit are you using?
I just recompiled the latest CVS and get the same error.

If I change the user's primary group to that of a group defined in the
jk_lsh.ini file, and chgrp <primary group name> /home/<username> (the
jailed home directory), then then the jailed sftp session is successfully

If I change the user so that their primary group and their username does
not have a definition in the jk_lsh.ini file, but there is a [DEFAULT]
section defined (just like above), then I still get this error:

both the user myuser and the group myuser have no section in the
configfile /etc/jailkit/jk_lsh.ini

Apparently something is different between our configurations because the
[DEFAULT] section appears to be ignored on my system.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]