[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] owner / group problem

From: Olivier Sessink
Subject: Re: [Jailkit-users] owner / group problem
Date: Mon, 08 May 2006 20:13:04 +0200
User-agent: Thunderbird (X11/20060501)

Teppo Kauppinen wrote:
Teppo Kauppinen wrote:

   I have a small problem with jailkit, it does not recognize owners or
   groups of files and folders. I can login with SSH, but when I do "ls
   -l", it shows like

   drwxr-xr-x  2 1002 100 48 May  5 10:29 testuser

   drwxr-xr-x  2 0 0 792 May  5 10:28 bin
   drwxr-xr-x  2 0 0  96 May  5 10:30 dev
   drwxr-xr-x  2 0 0 232 May  5 10:28 etc
   drwxr-xr-x  3 0 0  72 May  5 10:29 home
   drwxr-xr-x  3 0 0 360 May  5 10:28 lib
   drwxr-xr-x  3 0 0 648 May  5 10:28 lib64
   drwxrwxrwx  2 0 0  48 May  5 10:30 tmp
does user root exist in the jail/etc/passwd ?

yes, but it does not even recognize the user "testuser" which I use to log in (as you can see from the testuser home dir).

Here's the jail/etc/passwd.

here's jail/etc/group

here's /etc/passwd

here's what's in /var/log/messages (no errors, just this)
May 8 09:03:27 ssh1 jk_chrootsh[6801]: now entering jail /JAIL for user testuser (1002)

# scp java3d-re-1.3.1-linux-amd64.bin address@hidden:/home/testuser
unknown user 1002
lost connection

   I've tried both JailKit 1.3 and 2.0 and I'm using SuSE10 64bit. I've
   managed to make it work in SuSE10 32bit version, I had no problems
   that time. I even tried the same CVS snapshot that works on my
   laptop (the one where the 32bit SuSE is) but it didn't work either
   (home directory %s differs from jail home directory %s)

   So my questions are:
   1. Has any of you guys faced this problem before? Is there a known
   solution for it?
   2. Could it be that jailkit does not work in 64bit SuSE10 although
   it works in 32bit version?
the cvs version of jailkit is tested on suse64, I'm not sure about 2.0..

I did only the "jk_init -v /JAIL basicshell" and "jk_init -v /JAIL scp", but that should not be the problem(?).

do all of the /lib/libnss*.so libraries exist in the jail? Perhaps there is a problem in those libraries..

else you might want to use strace to track down the problem, one of the howto's on the website explains how to use it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]