[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] Identity problem [SOLVED]

From: Rui Ramos
Subject: [Jailkit-users] Identity problem [SOLVED]
Date: Fri, 10 Feb 2006 10:35:34 +0000

 Hy Stephen and thanks on the reply,

  I've chek that in $JAIL/etc/passwd and $JAIL/etc/group and they where there. 
I also had the libraries but i missed something, so here goes to some one that 
as the same problem.

 I did inclued in $JAIL/etc/ld.so.conf the path for the libs required for 
whoami program. then i enter with root user and execute the ldconfig command to 
update the libs. i get the an output that it was excpeting the symlink for the 
 so i did that:
   ln -s /lib/libnsl.so.1 libnsl-2.3.2.so
   ln -s /lib/libnss_compat.so.2 libnss_compat.so
   ln -s /lib/libnss_dns.so.2 libnss_dns.so
   ln -s /lib/libnss_files.so.2 libnss_files.so
   ln -s /lib/libnss_nis.so.2 libnss_nis.so
   ln -s /lib/libnss_nisplus.so.2 libnss_nisplus.so

 that i could execute ldconfig and that's it 

> Hello Rui,
> >  But when i got to the part of testing i could log with ssh but i got 
> > allways connection rejected. It seems like a perission problem. I've search 
> > a lot and still didn't find the issue. So i've testiing jail instead of 
> > jk_chrootsh shell in /etc/passwd and now it works. I still use the jk_* 
> > commands. 
> I'd also guess you're having a permission problem. Have you checked the log 
> file for entries from jk_chrootsh? Those entries are very informative and 
> usually give the precise reason why jk_chrootsh didn't allow changing to the 
> chroot directory. If jailkit messages don't give you the reason, check you 
> log files for any "error" or "denied" messages from your SSH daemon.
> >  One problem i have is the identity.
> > 
> >   i can logging to the chroot env bu i get in the prompt: "I have no 
> > address@hidden:"
> >  
> >  executing whoami i get:
> > 
> >  whoami: cannot find username for UID
> Have you forgotten to add a user or group to JAILDIR/etc/passwd or 
> JAILDIR/etc/group? This might happen if you've decided to "add" users 
> manually to the jail directory.
> Does "whoami" have all required libraries? Execute "ldd /bin/whoami" and 
> check if those libraries (.so) exist in the chroot directory (JAILDIR/lib/).
> Cheers,
> Stephen
 Rui Manuel dos Santos Ramos

 Instituto de Recursos e Iniciativas Comuns
 Pra├ža Gomes Teixeira, 4099-002 Porto, Portugal

 phone : +351 223 401 571
 e-mail: rramos[at]iric.up.pt
    web: http://ruiramos.no-ip.com

Attachment: pgpR050KcPk1Z.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]