[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compilation problems under Solaris 2.6

From: John W. Eaton
Subject: Compilation problems under Solaris 2.6
Date: Mon, 5 Oct 1998 20:07:02 -0500 (CDT)

On  5-Oct-1998, Todd Ellenberger <address@hidden> wrote:

| I have tried unsucessfully to install octave 2.0.13 on a Sun Ultra
| 60 running Solaris 2.6 using both the gcc-2.8.1 and egcs-1.1b
| compilers.  I am using gnu make, gnu libraries, g77, etc with my
| path set to find the gnu compilers. I have tried both static and
| dynamic builds. Everything compiles fine until the step listed
| below. I have tried compiling with and without the -g flag. I have
| looked through the past archives and did not find anything
| conclusive (I did find the patches to, pt-exp.h, and
| pt-mvr-base.h helpful for compiling under the egcs1.1b
| compiler). Any help would be greatly appreciated!

| rand.o: In function `curr_rand_seed(void)':
| rand.o(.text+0x8c): undefined reference to `getsd_'

My guess is that on your system, g77 is not appending an underscore to
external function names, but the calls to them are set up assuming
that an underscore will be appended.  Octave's configure script
includes a check for this feature.  Can you see why it might be


reply via email to

[Prev in Thread] Current Thread [Next in Thread]