[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem loading numpy and other on a venv in a guix system

From: mprodrigues
Subject: Problem loading numpy and other on a venv in a guix system
Date: Tue, 29 Nov 2022 16:42:14 +0000


I've been using a guix shell with a couple of python packages and it works fine, however I'd also like to keep the option of using a virtualenv if possible, the thing is I'm having problem running modules like numpy, that depend on non python dependencies. The error I get when I try to load numpy in a venv is:

Importing the numpy C-extensions failed. This error can happen for many reasons,
often due to issues with your setup or how NumPy was installed.

and in the end:

Original error was: cannot open shared object file: No such file or

I have tried installing zlib directly, also tried to add my default profile libs path to the venv PATH, but to no avail until now. How can I solve this? Or maybe someone can point me in the direction that I have to take to properly
debug this.

Best regards,
Mateus Rodrigues

reply via email to

[Prev in Thread] Current Thread [Next in Thread]