[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Errors running kicad GUI package in container

From: Luis Felipe
Subject: Re: Errors running kicad GUI package in container
Date: Tue, 01 Nov 2022 15:54:03 +0000

------- Original Message -------
On Tuesday, November 1st, 2022 at 15:09, Peter Polidoro <> 

> > For what it's worth, kicad seems to work for me in a container.
> > I'm using Guix System with GNOME (guix 4716cea):
> > 

> > __________
> > guix shell kicad -E "^DISPLAY$" -E "^XAUTHORITY$"
> > --expose="$XAUTHORITY"
> > --expose=/tmp/.X11-unix/ --expose=$HOME/.Xauthority
> > --expose=/etc/machine-id
> > --expose=$HOME/Descargas --expose=/tmp/dbus-fnAz1hb4to
> > ‾‾‾‾‾‾‾‾‾‾


> Thanks! Although when I try this, I still get the warning about
> failing to connect to the accessibility bus and I still get the
> gdk-pixbuf-error.

Bah. So does "/run/user/1000/at-spi/bus_0" exists in your system? If it does 
exposing it would probably make the accessibility warning go away. I see 
similar messages myself when running GUI apps but need to expose a different 
file (see below).

I don't know what's the best way to fix the pixbuf error; I'd simply do what 
you already did: included the gdk-pixbuf package in the command. I don't know 
if that would mean the kicad package should be modified to include it.

> What are the last two directories that you are exposing? Is the
> first just your home directory or is it some kicad specific
> directory in your home directory? How do you find the name of the
> second directory and is that for the accessibility bus or
> something else?

You can ignore "--expose=$HOME/Descargas" which is just a directory from which 
I read files when using my application.

As for "--expose=/tmp/dbus-fnAz1hb4to", it's the file I always have to provide 
to avoid this error:

( Gtk-CRITICAL **: 15:22:47.557: Unable to connect to the 
accessibility bus at 
'unix:path=/tmp/dbus-fnAz1hb4to,guid=7edf085d4bc4b153351b79bb635ea1b4': Could 
not connect: No such file or directory

This file changes when you reboot the system, so you always have to update your 
container command. I looked for possible environment variables that could 
define it, but could not find anything.

I also migrated my application to GTK 4 recently and found a new warnings, and 
they can't be ignored because the application misbehaves if you don't fix them 
(some GUI interactions freeze interaction with the whole GNOME Shell):

libEGL warning: MESA-LOADER: failed to retrieve device information
libEGL warning: DRI2: could not open /dev/dri/card0 (No such file or directory)
libGL error: MESA-LOADER: failed to retrieve device information

My current fix is to expose "/dev/dri/card0". I haven't investigated what's the 
best thing to do.

Attachment: publickey - - 0x12DE1598.asc
Description: application/pgp-keys

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]