[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Errors running kicad GUI package in container

From: Peter Polidoro
Subject: Re: Errors running kicad GUI package in container
Date: Tue, 01 Nov 2022 11:09:57 -0400
User-agent: mu4e 1.8.11; emacs 28.2

For what it's worth, kicad seems to work for me in a container. I'm using Guix System with GNOME (guix 4716cea):

guix shell kicad -E "^DISPLAY$" -E "^XAUTHORITY$" --expose="$XAUTHORITY" --expose=/tmp/.X11-unix/ --expose=$HOME/.Xauthority --expose=/etc/machine-id
--expose=$HOME/Descargas --expose=/tmp/dbus-fnAz1hb4to

Thanks! Although when I try this, I still get the warning about failing to connect to the accessibility bus and I still get the gdk-pixbuf-error.

What are the last two directories that you are exposing? Is the first just your home directory or is it some kicad specific directory in your home directory? How do you find the name of the second directory and is that for the accessibility bus or something else?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]