[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Typing on GuixSD in languages other than English

From: Chris Marusich
Subject: Re: Typing on GuixSD in languages other than English
Date: Sat, 09 Apr 2016 12:38:54 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

address@hidden (宋文武) writes:

> Chris Marusich <address@hidden> writes:
>> Luis Felipe López Acevedo <address@hidden> writes:
>>>> Chris Marusich <address@hidden> writes:
>>>> The attached patches add anthy and ibus-anthy.  They build OK.
>>>> However,
>>>> Japanese input is not yet working for me.  In fact, ibus itself does
>>>> not
>>>> seem to be working at all.
>>>> How can I verify that ibus is working on its own?  I've tried
>>>> installing
>>>> ibus by itself into my profile.  When I do this, I can run ibus-setup,
>>>> and I see a "Japanese" language input option.  This is true even when
>>>> anthy and ibus-anthy are not installed, which surprised me. I had
>>>> expected to find no Japanese language input options at all in
>>>> ibus-setup
>>>> when anthy and ibus-anthy are not installed.
>>>> In GNOME, there is no ibus menu visible anywhere on my screen, so it is
>>>> unclear whether ibus is actually working.  When I open Gedit and press
>>>> <Super>+Space, my input method does not seem to change.  According to
>>>> ibus-setup, this hotkey should change my input method.  However, it
>>>> seems like ibus is just not working at all.
>>> FWIW, this is what I do on Debian 8 (with GNOME SHELL):
>>> - Install ibus, ibus-anthy (or ibus-mozc).
>>> - Restart the system.
>>> - Go to *System settings → Region & Language*.
>>> - Add *Japanese (Anthy)* in Input method.
>> "Japanese (Anthy)" does not show up as an input method.  There are a
>> variety of entries (which are present regardless of whether ibus, anthy,
>> or ibus-anthy are installed), and none of them mention "Anthy".
> The exec path in the anthy.xml is wrong, also we need wrap them with
> python-pygobject.  I fixed that and pushed.
> Thanks!

Awesome!  Where you able to get this working?  I've tried installing it
From the version you pushed, and I still can't get it to work.  Even
when I set all the environment variables mentioned, and I install all
the packages (ibus, ibus-anthy, and anthy) to my profile.  If you got it
working, I'd like to know how so I can set it up on my end, too.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]