[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Typing on GuixSD in languages other than English

From: Chris Marusich
Subject: Re: Typing on GuixSD in languages other than English
Date: Mon, 04 Apr 2016 23:48:52 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Ricardo Wurmus <address@hidden> writes:

> Chris Marusich <address@hidden> writes:
>> How can I verify that ibus is working on its own?  I've tried installing
>> ibus by itself into my profile.  When I do this, I can run ibus-setup,
>> and I see a "Japanese" language input option.  This is true even when
>> anthy and ibus-anthy are not installed, which surprised me. I had
>> expected to find no Japanese language input options at all in ibus-setup
>> when anthy and ibus-anthy are not installed.
> It’s a bit tricky.  IBus caches input methods and reads them from the
> cache.  This is also the reason why IBus breaks whenever it is updated
> (see bug #22707).
> This cache is in “~/.cache/ibus/bus”.

Thanks for the heads-up.  I've installed ibus to my profile, but I
haven't updated it (to my knowledge).  There is currently no sign that
the cache is causing ibus to malfunction.

> Another thing you might need to store settings for IBus is to run
> “libexec/dconf-service” of the “dconf” package.

According to "ps auxww", there is already a "dconf-service" running
under my user name.  There is currently no sign that dconf-service is
causing ibus to malfunction.

> Then I had to set
>     IBUS_COMPONENT_PATH=$HOME/.guix-profile/share/ibus/component
> and the usual
>     QT_IM_MODULE=ibus
>     address@hidden
>     GTK_IM_MODULE=ibus
> You will also need
>     GUIX_GTK2_PATH=$HOME/.guix-profile/lib/gtk2.0
>     GUIX_GTK3_PATH=$HOME/.guix-profile/lib/gtk3.0
> so that GTK+ can find the input method modules for ibus in your profile.
> Then it should work in a GTK+ application such as “xfce4-terminal”.
> Don’t try it in Emacs because it probably won’t work without even more
> fiddling.

I tried adding all of these to my ~/.bashrc (I rebooted after doing this
to ensure that my environment would get configured correctly)

--8<---------------cut here---------------start------------->8---
export IBUS_COMPONENT_PATH="$HOME/.guix-profile/share/ibus/component"
export GTK_IM_MODULE=ibus
export address@hidden
export QT_IM_MODULE=ibus
export GUIX_GTK2_PATH="$HOME/.guix-profile/lib/gtk-2.0"
export GUIX_GTK3_PATH="$HOME/.guix-profile/lib/gtk-3.0"
--8<---------------cut here---------------end--------------->8---

Note that I've added hyphens (e.g., I wrote "gtk-2.0" instead of
"gtk2.0") because on my GuixSD system, those are the correct paths.

However, even with these environment variables set, all behavior remains
unchanged from before.  Because there appears to be essentially no error
feedback (for example, where are the logs showing what ibus is up to?),
it's difficult to tell what the problem might be.

Perhaps because there are holes in my understanding of ibus, GNOME, GTK,
QT, XIM, and input methods on GNU/Linux in general, I feel as though I
am grasping at straws at this point.  I have reviewed the ibus
documentation, but things are still unclear to me.

> This is all not nice yet and I’ve only managed to get the Pinyin input
> method to work (until the next upgrade).  I haven’t been able to get any
> of the included input methods (like Arabic) to work at all.
> This needs more work and I’d appreciate some assistance!

Can you tell me exactly how you set up the Pinyin input method?  Perhaps
I can replicate that on my end, if only to verify that my environment is

Going forward, perhaps we should ask for help from the ibus user [1] or
[2] developer group, look at how other distros have packaged ibus [3], or
try one of the unstable GNOME 3.5.x versions which integrate ibus into
GNOME [4].  What do you think?

[3] For example:


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]