help-grub
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

on booting my vm I get grub> prompt instead of menu


From: John Covici
Subject: on booting my vm I get grub> prompt instead of menu
Date: Fri, 27 Jul 2018 10:01:32 -0400
User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI-EPG/1.14.7 (Harue) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 EasyPG/1.0.0 Emacs/26 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

Hi.  I am a newbie with grub, so please bear with me on this.

I have a vm at linode -- I don't know if that makes any difference,
but I thought to mention it.  Now in this vm, I have installed grub on
/dev/sda and while doing this /dev/sda1 was mounted on /boot.
grub-mkconfig was successful.  /dev/sda2 contains a number of lvm
volumes one of which is the root volume specified in the kernel.  What
happens is when I boot up the system, I have to access the serial
console which I can do to see what is happening and I get just a grub>
prompt.  Now if I type exit, it says booting from hard disk and I get
the menu and things boot normally.

Can someone help me figure out why this is happening and how to fix?
I am using Debian 8 on that vm.  Let me know if you need more information.

Thanks in advance for any suggestions.

-- 
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         address@hidden



reply via email to

[Prev in Thread] Current Thread [Next in Thread]