[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub with serial line configuration using PCI serial adapter

From: rishat
Subject: Re: grub with serial line configuration using PCI serial adapter
Date: Wed, 19 Oct 2016 12:20:54 +0300
User-agent: Roundcube Webmail/1.2.0

lspci -nn
01:06.0 Serial controller [0700]: MosChip Semiconductor Technology Ltd. PCI 9835 Multi-I/O Controller [9710:9835] (rev 01)

With best regards

On 2016-10-19 06:40, Andrei Borzenkov wrote:
18.10.2016 23:05, Songatov Rishat пишет:

lspci -i in the grub environment shows me this:

01:06.0 9710:9835 [0700] Communication controller [PI 02]
IO space 0 at 0xac00
IO space 1 at 0xa880
IO space 2 at 0xa800
IO space 3 at 0xa480
IO space 4 at 0xa400
IO space 5 at 0xa080

The same when OS is loaded:

01:06.0 Serial controller: MosChip Semiconductor Technology Ltd. PCI
9835 Multi-I/O Controller (rev 01) (prog-if 02 [16550])
    Subsystem: LSI Logic / Symbios Logic 2S (16C550 UART)

Could you please show PCI IDs (lspci -nn ...)?

Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 10
    Region 0: I/O ports at ac00 [size=8]
    Region 1: I/O ports at a880 [size=8]
    Region 2: I/O ports at a800 [size=8]
    Region 3: I/O ports at a480 [size=8]
    Region 4: I/O ports at a400 [size=8]
    Region 5: I/O ports at a080 [size=16]
    Kernel driver in use: serial

I think BIOS can't recognize this device as serial adapter. I will try
to other one. Thank you to your support.

On 18.10.2016 16:10, rishat wrote:
Yes, I saw this serial card from lspci output. But I haven't found how to display detailed information for certain card. Sooner I'll give you
output from lspci -i.

With best regards

On 2016-10-18 14:05, Andrei Borzenkov wrote:
On Tue, Oct 18, 2016 at 12:48 PM, rishat <address@hidden> wrote:
Hi Andrei
May I ask another question? How I can debug this behaviour? I
believe that
BIOS initializes this adapter. Need to say that "PnP OS" was setted
to "Yes"
value. I've changed it to "No" and ... same silence in the minicom.

Well, assuming BIOS did initialize this card it may use different port
address. The one you see in setserial output is assigned by Linux
driver. I do not know how flexible it is, but I presume they may

Try lspci command in GRUB. Does it show your card at all? It also
displays some details of current card setup.

You may want to use "set pager=1" otherwise output will scroll too fast.

If you see your card could you send screenshot of information GRUB

Then I
pulled out this adapter and inserted this pci serial adapter to the
other PC
computer. It has already integrated COM port, this one is working
fine, I
have tried to do serial connection via pci adapter, but again I've got
nothing. I just want to figure out is this something I can do with
motherboard or my pci adapter is not compatible. If I need to change
card do you have list of pci, pci-e card that successfully can by
used? Is
it possible I've faced to situation when two motherboards can't
this hardware?

Thank you in advance.

Best regards

On 2016-10-18 06:47, Andrei Borzenkov wrote:

17.10.2016 22:22, Songatov Rishat пишет:

Hi thank you for helping me!

Unfortunately I haven't got serial access to the grub after adding
piece of configuration:

insmod pci
insmod serial
insmod terminal
insmod terminfo

###serial --speed=115200 --port=a880 --word=8 --parity=no --stop=1
serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1

terminal_input serial
terminal_output serial

May be I need some sleep time after inserting pci.mod. How I can
do this?

You can pause with "sleep NN" but as I already wrote this is not
to work anyway - either GRUB needs code to initialize your PCI card or
BIOS should do it. Try BIOS settings, in the past it was common to
something like "PnP OS" where "no" would cause BIOS to initialize all
available hardware and "yes" would leave it to operating system.


Best regards


On 17.10.2016 20:34, Andrei Borzenkov wrote:

17.10.2016 19:41, rishat пишет:

On 2016-10-17 19:16, Andrei Borzenkov wrote:

17.10.2016 16:16, rishat пишет:

setserial -g /dev/ttyS[0-4]
/dev/ttyS0, UART: 16550A, Port: 0xa880, IRQ: 21


When I tried to manually type a "serial --speed=115200 --unit=0
--parity=no --stop=1" in the grub command line it complains
that COM1
port don't exist. I have played with unit and port attributes but
without any luck.

Does "serial --port=a880 ..." work? If not, what exactly happens?

Note that you may need to load at least PCI bus driver (insmod
this to work.

I've tried to use it that way but it didn't find com port again.
I'll try to do insmod pci and write to you tomorrow.

Yes, please let us know, but on firther consideration it probably
help either. Card likely needs to be initialized first, and this
requires driver that knows how to do it. serial driver in GRUB
hardware is in working state already. Someone would need to

By the way is it possible to share documentation about some useful modules in the grub? I havn't found any information using google.

Help-grub mailing list

Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]