[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ASRock A785GMH/128M fails to find devices when in RAID mode and disk

From: Xen
Subject: Re: ASRock A785GMH/128M fails to find devices when in RAID mode and disks are present
Date: Thu, 04 Aug 2016 00:09:10 +0200
User-agent: Roundcube Webmail/1.2.0

Xen schreef op 01-08-2016 22:01:
I am probably sending this motherboard off tomorrow to a guy that
wants to have it and who has buyers that do not care about Linux or
RAID, apparently.

I guess you don't want to fix these issues.

Happens a lot that people just don't want to fix anything unless pulled to it by their hair ;-) (or arms).

One thing that is noteworthy is that I discovered that on some (Kubuntu) kernel update (or actually, my own update-grub calls that supposedly would have executed my freshly compiled Git version grub-mkconfig the selected kernel was chosen to be the efi variant.

The motherboard most definitely did not support UEFI.

The first time I booted this system with another motherboard it went fine, the times after I got a kernel panic in not finding any root filesystem which was solved by either selecting the root device (for boot) directly as (lvm/linux-boot) instead of the UUID string, or by selecting the regular non-efi kernel.

My appreciation for you Andrei is growing less by the day. Not that it should matter to you or anyone.

You are very good at not responding when someone does work for you.

Kinda like to waste people's time I guess, that you would probably accuse me of.

Instead of helping me find the issue you are only interested in whether the issue should be located in Grub or not.

And then you are probably angry with me not keeping the board at our (me) disposal as well.

It should be fully obvious that Windows is going to boot the array just fine, ASROCK had a complete manual dedicated to RAID install just for this mobo. So I have no clue what other boot loaders I could try, but you also did not tell.

How am I supposed to know these things, the days of LILO are long past (well, for me at least) and I have no expertise in that.

I spend so much time and you just don't care. It's not good enough or something, not professional enough or not smart enough, not open source enough, I don't know. You are the only one that reponds to anything to begin with.

I can understand that it is not your dayjob or anything to work on Grub, but there are other people who's dayjob it is (to work on their specific project) and they are sometimes equally as reluctant ;-). Last time I filed a bug somewhere it took the intervention of another employee of that company for anything to happen. The response was the same as your response has been here: is this a problem with our software or not? In that case it was a documentation bug that also belonged to that company, but the engineer didn't want to fix it because it was not part of his core project and he turned the bug report to notabug or wontfix.

I had to reopen it after which some other employee assigned it to the proper team.

I am not in the position to determine whether it is a sole Grub problem or not because I need your help for that, I do not have the knowledge that you do; so how could I do your work? I am not your equal in this. I am a peasant compared to a king, if that is at all an appropriate comparison. I have never worked in IT and I have been ill for 10 years at least (12 actually). I have no professionals around me that can help me with this and I have to do everything on my own.

My potential for doing work is also often severely limited and yet I am asked to answer questions I can barely even know about.

I mean if you don't want it fixed, fine, someone else might run into it, or not. I just sold the thing and try to use something else, but I already have shitload of problems with that as well.

(Some cheap firmware RAID card is causing LVM not to load correctly after a crypt device has been opened, merely by being installed in the system. A non-encrypted PV installed directly on disk in another system (by the pvinstall patch) works fine. Flabbergasted once more, you install a simple PCIe card, and Linux doesn't boot anymore. There is just no end to the amount of work I have to do to just get something running. It gets past grub, it loads the initrd, the initrd unlocks the LUKS, and then the root volume (on LVM) is not found, bam, just like that. But because the initrd obviously doesn't save any logging, and there is also not any output, I will have to adjust it to do any debugging at all. Which is kinda hard to do usually on an empty stomach with no reliable main system you can ever depend on. I just need help, but everyone seems to assume that everyone is created equal and what they can do, I should be able to do as well.

Mostly people try to get other people to do their job, is what I see. And if those people can't do it, tough luck, you're on your own (that I already was at the beginning).)

You are always respectful Andrei and consise, but just not very helpful.

Then when there are some WD support people on some forums, they comliment people on what they can instead of what they can't.

Even so I guess I just should get outta here again, and stop working on this.

It's just a huge time sink and I would be happier just playing some game, but I can't because Windows destroyed its boot sequence once more (due to this controller as well) and apparently overwrote some boot information that can now, of course, never be repaired again. There are just no stable systems anymore. At least, not for me.

I guess I should just be gone then, I don't know.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]