[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

fallback option doesn’t work

From: Николай Сулейманов
Subject: fallback option doesn’t work
Date: Wed, 1 Jun 2016 12:38:27 +0300

I’ve set up grub with the following config:

set default=tftp
set fallback=sysrcd32
set timeout=7

insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
search --no-floppy --set=root --fs-uuid 12345678-1234-1234-1234-123456123456

menuentry 'TFTP boot' --id tftp {
    insmod net
    insmod tftp
    set net_default_server=
    linux (tftp)/rescue32 setkmap=us nonm scandelay=1
    initrd (tftp)/initram.igz

menuentry 'Custom SystemRescueCd x86' --id sysrcd32 {
        loopback loop /sysrcd.iso
        linux (loop)/isolinux/rescue32 isoloop=sysrcd.iso
        initrd (loop)/isolinux/initram.igz

But when grub fails at ‘tftp’ menuentry, is writes ‘Failed to boot both
default and fallback entries’. I’ve tried to replace the IDs with numbers 0
and 1 for default and fallback entries respectively, but that did not help.
If I change the iso file name to a non-existing one, then make ‘sysrc32’
the default and tftp the fallback, grub shows the same error anyway.

# grub2-install --version
grub2-install (GRUB) 2.02~beta3

reply via email to

[Prev in Thread] Current Thread [Next in Thread]