[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: fallback option doesn’t work

From: Andrei Borzenkov
Subject: Re: fallback option doesn’t work
Date: Wed, 1 Jun 2016 22:27:24 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.8.0

01.06.2016 12:38, Николай Сулейманов пишет:
> I’ve set up grub with the following config:
> set default=tftp
> set fallback=sysrcd32

fallback value must be numeric (list of numbers). I believe it had been
discussed, we need to find backward compatible way to extend it. So far
"fallback" is really used only by legacy grub menu parser.

> set timeout=7
> insmod gzio
> insmod part_gpt
> insmod ext2
> set root='hd0,gpt3'
> search --no-floppy --set=root --fs-uuid 12345678-1234-1234-1234-123456123456
> menuentry 'TFTP boot' --id tftp {
>     insmod net
>     insmod tftp
>     set net_default_server=
>     net_bootp
>     linux (tftp)/rescue32 setkmap=us nonm scandelay=1
>     initrd (tftp)/initram.igz
> }
> menuentry 'Custom SystemRescueCd x86' --id sysrcd32 {
>         loopback loop /sysrcd.iso
>         linux (loop)/isolinux/rescue32 isoloop=sysrcd.iso
>         initrd (loop)/isolinux/initram.igz
> }
> But when grub fails at ‘tftp’ menuentry, is writes ‘Failed to boot both
> default and fallback entries’. I’ve tried to replace the IDs with numbers 0
> and 1 for default and fallback entries respectively, but that did not help.

It works for me. I tested with numerical "fallback" and it correctly
boots using fallback entry. I tested with non-existing file names, so
that both menu entries referred to disk, no network.

Start with making sure which menu entries are executed. Add something like

"echo $1"
sleep 5

to each so it prints title when executing it.

> If I change the iso file name to a non-existing one, then make ‘sysrc32’
> the default and tftp the fallback, grub shows the same error anyway.
> # grub2-install --version
> grub2-install (GRUB) 2.02~beta3

I tested under openSUSE Tumbleweed which is usign 2.02~beta3.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]