[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 chainloader bootmgfw.efi not working

From: Vyacheslav Gonakhchyan
Subject: Re: Grub2 chainloader bootmgfw.efi not working
Date: Sun, 27 Sep 2015 12:55:44 +0300

Solved this. Motherboards sees loads grubx64.efi and grub works after I fixed partition order and overwritten GPT table.
"So fdisk hinted that partition order was incorrect(it's a warning). I fixed partition order with special option in expert mode and overwritten GPT table."
More details here:

On Thu, Sep 17, 2015 at 10:52 AM, Vyacheslav Gonakhchyan <address@hidden> wrote:
I've written several messages on acronis's site and to tech support. They don't answer. And I have their tech support for several months. I also have threads on several forums. The problem proved to be complex. Maybe because GPT and EFI are still fresh concepts and everyone's still thinking in terms of MBR.

I thought I had logs to understand what happened but it seems that operation was not logged.
The next step is to try load windows with edited bcd because right now it does not load and it has no such mode as grub rescue to point to correct partition.

>It is possible that Acronis did something to filesystem on ESP
Quite possible. It was a surprise for me when I chose to resize adjacent partitions and acronis decided to move around some stuff. I should have made a photo of the error then. I thought it works like transactional database and does not break anything. I was wrong - it broke NTFS on my windows D:. I could not recover MFT (Master File Table with files locations) and did quick format as last cause. There is no valuable data, just a lot of installed programs. Also hoping chkdsk /f might add missing files back to MFT.

Thanks, you've helped a lot with my understanding of the problem. I will write once this is solved.

On Thu, Sep 17, 2015 at 6:49 AM, Andrei Borzenkov <address@hidden> wrote:
17.09.2015 06:32, Andrei Borzenkov пишет:

17.09.2015 00:11, Vyacheslav Gonakhchyan пишет:
That was probably incorrect usage of ddrescue :(
Here's more accurate output from
dd if=/dev/sda count=1 bs=512 skip=976773167

Do you know how to read it or it's just to make sure that it's gpt

I know GPT header structure if that's what you ask. I do not see any
problems either. You could try gdisk if it detects any problems,
otherwise I must apologize - I do not know what happens here. May be try
Acronis (or whatever you used to change layout) forums and/or support?

Just as an idea. It is possible that Acronis did something to filesystem on ESP; EFI normally does not show every possible partition, but rather the one it can work with.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]