[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 chainloader bootmgfw.efi not working

From: Andrei Borzenkov
Subject: Re: Grub2 chainloader bootmgfw.efi not working
Date: Wed, 16 Sep 2015 06:24:50 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.2.0

15.09.2015 22:40, Vyacheslav Gonakhchyan пишет:
map -v
Mapping table
       FS0: Alias(s):F7f0b0:;BLK5:
          Handle:      [C5]
          Media Type:  Unknown
          Removable:   Yes
          Current Dir: FS0:
      BLK0: Alias(s):
          Handle:      [CC]
          Media Type:  Unknown
          Removable:   No
          Current Dir: BLK0:
      BLK2: Alias(s):
          Handle:      [CD]
          Media Type:  Unknown
          Removable:   No
          Current Dir: BLK2:
      BLK4: Alias(s):
          Handle:      [CE]
          Media Type:  Unknown
          Removable:   No
          Current Dir: BLK4:
      BLK1: Alias(s):

          Handle:      [CF]
          Media Type:  HardDisk
          Removable:   No
          Current Dir: BLK1:
      BLK3: Alias(s):

          Handle:      [D0]
          Media Type:  HardDisk
          Removable:   No
          Current Dir: BLK3:

So everything is bad because my MB(ASUS *M5A97*) suddenly cannot discover
gpt partitions?

This explains GRUB behavior. But now I'm extremely confused - can your system actually boot? Where does it boot from? Could you show "efibootmgr -v" output?

I have not said it in first mail but this boot situation
started after I tried to resize one partition in Acronis Disk Director 12
and it failed. Maybe it did something to gpt tables. But archlinux can work
with them so it's strange.

So does GRUB. Could you attach the first 1K and the last sector from this disk? And, BTW, is disk 512b or 4K?

On Tue, Sep 15, 2015 at 1:14 PM, Andrei Borzenkov <address@hidden>

On Tue, Sep 15, 2015 at 12:28 PM, Vyacheslav Gonakhchyan
<address@hidden> wrote:
Attached devtree output. Don't have serial console so provided image

Do you see entry corresponding to hd1,gpt7?
Only HD entries I see:
Entire lsefi output:

ls -l output:

Well, you firmware sees two partitions - (hd2,msdos2) and what is
probably protective MBR on hd1. It does *NOT* show any trace of GPT
partitions on hd1.

Could you please boot EFI Shell and attach output of "map -v" command?

On Tue, Sep 15, 2015 at 6:56 AM, Andrei Borzenkov <address@hidden>

15.09.2015 01:18, Vyacheslav Gonakhchyan пишет:

I installed grub-git and efibootmgr-git and reproduced it.
If it matters could not build efivar-git so it's few month behind.

Could you please run "lsefi" in GRUB CLI and look for paths ending with
HD(...). It is structured as


Do you see entry corresponding to hd1,gpt7?

Unless you have serial console you want to do

set pager=1

otherwise it will scroll too fast. Keep in mind that there is no way to
abort output once started you will have to keep paging it until end. If
have serial console, could you attach output as well as "ls -l"?

Could you also boot EFI Shell and attach output of "devtree" (you can
redirect to a file on ESP).

On Mon, Sep 14, 2015 at 7:42 PM, Andrei Borzenkov <address@hidden


14.09.2015 15:36, Vyacheslav Gonakhchyan пишет:

My Grub2 is EFI. I use grub-install --target=x86_64-efi
--efi-directory=/boot/efi /dev/sda which calls efibootmgr to load
grubx64.efi into UEFI BIOS.

OK in this case message means that grub cannot find EFI handle for
(i.e. in your case - partition gpt7). GRUB itself needs just disk
and handles partitions internally. But when launching external binary
wants to pass it reference to device where it is located which means
must be exported and accessible by firmware.

The first step would be to try to reproduce it using upstream sources.

echo $grub_cpu $grub_platform

Sorry, can only check it later. I'm guessing x86_64, efi-64...

On Mon, Sep 14, 2015 at 4:11 PM, Andrei Borzenkov <

On Mon, Sep 14, 2015 at 2:36 PM, Vyacheslav Gonakhchyan

<address@hidden> wrote:

Hi, everyone!

I have dual boot config Archlinux/Windows7 and latest packages. I


into grub rescue mode. Or use command line. I want to tell Grub2 to
Windows Boot Loader bootmgfw.efi. Basically grub2 refuses to do it
error "invalid root device".

Steps to reproduce:

set root=(hd1,gpt7)
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

Screen is flashing with "invalid root device".

Is your grub BIOS or EFI? What are values for grub_cpu and

echo $grub_cpu $grub_platform

So grub2 finds bootmgfw.efi but cannot give it control. I tried


hd1,gpt combination to no avail.  I also tried setting root to one
and loading bootmgfw.efi from another device(hd1,gpt7).
It's strange because I can load this file from shell (shellx64.efi)


UEFI BIOS without error. Any advice is appreciated.


Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]