[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing grub2 with /boot on software raid

From: Wesley PA4WDH
Subject: Re: Installing grub2 with /boot on software raid
Date: Tue, 2 Jul 2013 12:10:37 -0700 (PDT)

Hi Jordan,

--- On Tue, 7/2/13, Jordan Uggla <address@hidden> wrote:
> In the future please include all relevant information in
> your email
> directly; It makes replying inline easier and I'm personally
> often in
> areas where my internet connection is unreliable and using a
> browser
> is much more difficult than reading email.

Ok, i'm sorry. I did consider both options, and because there was a lot of text 
i thought a link would be the best option.

pc12 grub2 # grub-install --no-floppy /dev/sda
/dev/md0 does not have any corresponding BIOS drive.

> -----%<----- explanation of the use of
Thanks for explaining, that really makes it more clear why i was doing things 
that didn't work out.

> This is clearly not your use case, your array will need to
> be
> assembled by grub at boot, so you should not be creating a
> and it is expected that grub will fail to boot with such a
> configuration. Please correct any incorrect Gentoo
> documentation if
> possible.

That was actually not in the gentoo docs but i found it on a few websites.
I'll double-check that.

> As to the problems you're having without the invalid
> entries, I'm not sure what the problem there is but I've
> never tried
> to install grub to a "RAID1 array" with only one disk, so
> that may be
> the problem. If you can, try to create a normal RAID1 array
> with two
> devices (even two partitions on the same drive as a test).

Ok, of tried two things:
First i removed the md entry's from the and tried to install:

pc12 / # grub2-install /dev/sda
*** glibc detected *** /usr/sbin/grub2-probe: double free or corruption 
(fasttop): 0x00007f78e019c0b0 ***
After that a stacktrace (which i didn't include since my system doesn't have 
debugging symbols, if you think it's usable anyway i can send it).
This actually repeats three times.

Then i added an additional partition to my raid1 array, and waited for it to 
After that the behaviour was almost similar, but with a different error message 
at the end:
Path `/boot/grub2' is not readable by GRUB on boot. Installation is impossible.

Actually, the "double free corrution"s are new, it didn't do that yesterday so 
i'll check that out. 

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]