[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing grub2 with /boot on software raid

From: Jordan Uggla
Subject: Re: Installing grub2 with /boot on software raid
Date: Mon, 1 Jul 2013 17:45:10 -0500

On 7/1/13, Wesley PA4WDH <address@hidden> wrote:
> Hi All,
> I'm trying to do an installation of grub2 on a system where /boot is on a
> software-raid partition. However, i run into a few problems and never got
> further than a grub rescue shell when booting.
> I collected most information here:

In the future please include all relevant information in your email
directly; It makes replying inline easier and I'm personally often in
areas where my internet connection is unreliable and using a browser
is much more difficult than reading email.

Firstly, you should *never* include any device in
/boot/grub/ unless it will show up as an actual device as
detected by your machine's firmware at boot. 99.9% of the time a
/boot/grub/ is completely unnecessary with grub 2.00 or

The only valid use for a currently is to override grub's
detection that a device is actually an abstraction (like RAID or LVM)
and instead tell grub to treat it as a single real device. This is for
example useful when using LVM to prevision "drives" for virtual
machines and installing grub to these volumes from the host OS
(grub-install --boot-directory=/vm_root_mountpoint/boot/
/dev/mapper/my_logical_volume && kvm -hda
/dev/mapper/my_logical_volume ), so even though grub-install on the
host machine can clearly see that it is installing to a logical
volume, the virtual machine will see it as simply a hard drive (
/dev/sda when booted into GNU/Linux) and thus grub-install will
configure grub for that use.

This is clearly not your use case, your array will need to be
assembled by grub at boot, so you should not be creating a
and it is expected that grub will fail to boot with such a
configuration. Please correct any incorrect Gentoo documentation if

As to the problems you're having without the invalid
entries, I'm not sure what the problem there is but I've never tried
to install grub to a "RAID1 array" with only one disk, so that may be
the problem. If you can, try to create a normal RAID1 array with two
devices (even two partitions on the same drive as a test).

Jordan Uggla (Jordan_U on

reply via email to

[Prev in Thread] Current Thread [Next in Thread]