[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: PXE failure, alway enter rescue mode

From: #IS Department
Subject: RE: PXE failure, alway enter rescue mode
Date: Fri, 11 Feb 2011 10:29:29 -0700

Can you post the log and a list of your directory structure?  If the
prefix really is (pxe)/boot/grub then grub will look for
(pxe)/boot/grub/normal.mod and there should be a request in the tftp log
for /boot/grub/normal.mod which corresponds to
<wherever_your_tftpboot_is>/boot/grub/normal.mod on the local
filesystem.  For Ubuntu 10.10 the default folder for tftp-hpa is
/var/lib/tftpboot, so all your grub files should be under
/var/lib/tftpboot/boot/grub/.  Based on what you said, it's looking for
/normal.mod which would correspond to /var/lib/tftpboot/normal.mod,
which I'm guessing isn't there, hence the error message.  I don't
believe that it would have gone into rescue mode if it had actually been
able to access normal.mod.

The default configuration for tftp-hpa under Ubuntu 10.10 should be
sufficient to get pxe booting set up and running.  Depending on what
your end goal is you may have to tweak the settings from there.  The
permissions need to be at least read (and execute for directories) for
whatever user tftp is running as.  For Ubuntu 10.10 the default is to
run as tftp, so make sure the tftp user has sufficient permissions.

I'm not using grub 1.99rc1.  My distro was using grub legacy, so I tried
compiling grub 1.98 from source first.  It worked, so there was no
reason for me to run the release candidate.


-----Original Message-----
From: Cheng Cheng [mailto:address@hidden 
Sent: Thursday, February 10, 2011 10:00 PM
To: #IS Department
Subject: Re: PXE failure, alway enter rescue mode

Hi Rob,

I really really appreciate your reply. -:)

I use ubuntu 10.10 and tftpd-hpa as my TFTP server, and I turned on the
logging.  And the log show that grub has already download the module it
needs(normal). But I found the file name grub used is strange. There is
a "/" before the actual file name. For example, if I want to load
normal.mod, the log will shows: trying to get /normal.mod, which will
lead to fail. I do not know how to configure the TFTP to make both
/normal.mod and normal.mod work.

Can you send me your configuration file for TFTP, along with the
commands that you set up the privilege of "tftpboot" folder? And, do you
currently use 1.99rc1?

Thanks a lot!

Looking forward your rely. 


----- Original Message -----
From: "#IS Department" <address@hidden>
To: address@hidden
Sent: Thursday, February 10, 2011 7:03:25 PM
Subject: RE: PXE failure, alway enter rescue mode

The prefix looks fine to me (I used an identical command line for my
working setup).  My guess is the tftp server directory isn't set up
correctly.  I suggest you turn on logging (if your tftp server supports
it) to find out exactly what file is being looked for, and compare that
to the actual directory structure.  If your tftp server doesn't support
logging, then use a packet sniffer to see why the specified file is not


-----Original Message-----
From: address@hidden
[mailto:address@hidden On Behalf Of Cheng
Sent: Friday, February 04, 2011 8:43 PM
To: address@hidden
Subject: PXE failure, alway enter rescue mode

Hi all, 

I want to use PXE to boot GRUB. And I already have grub1.99rc1 on my

The command I used to produce the pxe image is:
   grub-mkimage --fromat=i386-pc-pxe --prefix='(pxe)/boot/grub'
--output=pxe.boot pxe pxecmd

But every time, I can only enter rescue mode. The error shows "file not

I think this is because the prefix has some problem, and grub cannot
resolve the path on tftp.

Can anyone tell me how to correctly set the prefix? I would really
appreciate it.


Help-grub mailing list

Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]