[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub-install to a partition

From: Goh Lip
Subject: Re: grub-install to a partition
Date: Sat, 09 Oct 2010 11:14:37 +0800
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100922 Thunderbird/3.1.4

On Saturday 09,October,2010 05:03 AM, Barry Jackson wrote:
Remember this? :-

menuentry 'PCLOS Live' {
linux (hd0,1)/isolinux/vmlinuz vga=788 livecd=livecd fromusb
root=/dev/sda1  acpi=on fstab=rw,noauto
initrd (hd0,1)/isolinux/initrd.gz

(Excuse wrapping) well, in my quest to get rid of sdxx, (hdx,y) and
UUIDs, I tried this:-

menuentry 'PCLOS Live test' {
search --no-floppy --label --set maingrub
linux /isolinux/vmlinuz vga=788 livecd=livecd fromusb
root=label=maingrub acpi=on fstab=rw,noauto
initrd /isolinux/initrd.gz

...and it works! go figure?

I wonder if grub version has a bearing on this? I am using 1.97 beta4
is that the latest? - and which are you using.

Another odd thing :-
this works also

menuentry 'Ubuntu 10.04' {
search --no-floppy --label --set ubuntu
chainloader +1

So why does Ubuntu's grub2 chainload when my 1.97b4 version won't?

Now I understand why most distros are cautious about moving to grub2 ;-/

Cheers - Barry

Yes, it's weird, but if you use the ubuntu's grub, that will be in line with what I expect because that's what I use. My version number is now at 1.98+20100804-5ubuntu3, but I had used 1.96 (I think) onwards and updated my dedicated grub partition continually to the latest and check the difference. Other than the minor changes in format which doesn't make a diff, like " " and ' ', ( ), (hd0,7) and '(hd0,msdos7)', the main diff is in the commands, like --overlay, --output, mkrescue etc.

Another odd thing, my previous message reports that I booted fine with "root=LABEL=xxxxx" while you could not. I did not mention, because I don't want to further confuse you, is that you booted fine without it *and* when I tried it without the line, it goes into the (initrams) busy box. Weird huh? I thought that since you booted okay now, after all the effort, I wouldn't want to burden you with more confusion.

So I rechecked the use of your label name, seems okay - less than 16 characters, underscore okay, etc. So it's really strange. I know I've edited out a lot of 'parameters' in my dedicated grub, like recordfail, savedfault, load_video, grubenv, gfxterm, gettext, but these shouln't make the difference in the problem we talked about. And I've confirmed with using the unedited (original) grub too to verify (configfile to the OS grub).

But if it now works for you, guess that's what matters most.
And, if you find out what's causing the weirdness, let us know.

So take care and regards - Goh Lip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]